[mythtv-users] mythtv issues at 4K (Intel NUC 12th Gen)

Hika van den Hoven hikavdh at gmail.com
Fri Nov 18 22:48:01 UTC 2022

Hoi Gabriel,

Friday, November 18, 2022, 11:03:38 PM, you wrote:

> So that's what I suspected, but the box has 16GB of RAM and runs
> nothing else but the myth frontend.

> There's nothing else logged in the Xorg.0.log to indicate any issues.

> I'm stumped, as I can't seem to turn up enough logging on either X
> or mythfrontend to generate a useful error to figure out why the frontend won't load.

> Is it possible it could be running short on video memory? I think
> the BIOS setting in the NUC has it set to "MIN 64 MB", and the only other option is "MIN 128MB".

> On Fri, Nov 18, 2022 at 12:37 PM Dan Wilga <mythtv-users at dwilga.info> wrote:

> On 11/17/22 2:19 PM, Gabriel Kuri via mythtv-users wrote:
 >> I have an Intel NUC 12th Gen that I loaded a mythfrontend on 
 >> (31/fixes). When X is running at 4K resolution (3840x2160), 
 >> mythfrontend won't load. Running it in the foreground generates the 
 >> following output. The X server didn't die, it's still there and 
 >> running fine...
 >> 2022-11-17 11:11:17.555931 I  OpenGL: Initialised MythRenderOpenGL
 >> 2022-11-17 11:11:17.555932 I  OpenGL: Using full range output
 >> 2022-11-17 11:11:17.556364 I  UICache: Pruning cache directory: 
 >> /home/mythtv/.mythtv/cache/remotecache
 >> 2022-11-17 11:11:17.556374 I  UICache: Kept 0 files, deleted 0 files, 
 >> stat error on 0 files
 >> 2022-11-17 11:11:17.556375 I  UICache: Pruning cache directory: 
 >> /home/mythtv/.mythtv/cache/thumbnails
 >> 2022-11-17 11:11:17.556377 I  UICache: Kept 0 files, deleted 0 files, 
 >> stat error on 0 files
 >> 2022-11-17 11:11:17.580900 I  CECAdapter: libCEC support is disabled.
 >> .752015 I  Qt: The X11 connection broke (error 4). Did the X11 server die?
 >> .753197 I  UDPListener: Disabling
 >> If I force mythfrontend to a lower geometry (ie 1080p), it comes up 
 >> fine. I can even go up to geometry 2000x1800, it loads. But as I 
 >> increase either the X or Y on the geometry, it will eventually get to 
 >> the point where it won't load and log the error "Qt: The X11 
 >> connection broke (error 4). Did the X11 server die?".
 >> I realize the GPU on this Nuc 12th gen is pretty new, I think it's an 
 >> Iris Xe ? I do have linux kernel 6.0.8 running to provide the latest 
 >> i915 driver and I also updated the intel-media-va-driver to 22.2.1.
 >> I also tried myth 32/fixes with the same result.
 >> I ran mplayer with a 4K test file and it plays.
 >> I'm not sure how to further debug the issue at this point. Anyone 
 >> running a newer Intel NUC 12th gen with the newer Alder Lake GPU ? Any 
 >> thoughts on what's going on?
>  I would look in the X server logs. The location depends on your distro,
>  but one common location is /var/log/Xorg.0.log. (Substitute the correct
>  X display ID for "0".)
>  My guess is that you could be running out of memory due to the much 
>  higher amount required for that resolution.
You can calculate the amount needed for one screenshot:
hres x vres x coldepth
For instance: 3840 x 2160 x 256 = 2025 Mbit or 253 Mbyte
As opposed to: 1920 x 1080 x 16 = 31,6 Mbit or 3,96 Mbyte

So I guess you need at least 512 Mb video memory, but better 1 or 2
Gbytes or even more.

Tot mails,
  Hika                            mailto:hikavdh at gmail.com

"Zonder hoop kun je niet leven
Zonder leven is er geen hoop
Het eeuwige dilemma
Zeker als je hoop moet vernietigen om te kunnen overleven!"

De lerende Mens

More information about the mythtv-users mailing list