[mythtv-users] Help needed as my mythtv-backend has lost it's mind (or maybe I have)

Peter Bennett pb.mythtv at gmail.com
Tue Nov 8 14:03:05 UTC 2022

On 11/8/22 08:27, James Abernathy wrote:
> On Tue, Nov 8, 2022 at 7:12 AM James Abernathy <jfabernathy at gmail.com> 
> wrote:
>     My backend is running fixes/32
>     (v32.0+fixes.202211050719.18f5b48ee1~ubuntu22.04.1)
>     The tuner is a Hauppauge WinTV quadHD ATSC PCIe card. This morning
>     I tried to do some maintenance which was only supposed to be
>     editing the Schedules Direct channel using
>     tv_grab_zz_sdjson_sqlite --manage-listing and that part went as
>     expected.
>     Next I ran mythtv-setup and it said it needed to shutdown the
>     backend and I said yes and it required the password.  I tried to
>     edit channels and scan but I kept getting failures with my tuner
>     card. Since I could not get it to recognize the card I exited
>     without saving and started the backend again. My remote frontends
>     could now connect to the backend and view Live TV.
>     At that point it was time to panic as usual, so I went back into
>     mythtv-setup and deleted all the tuners and started over.  I kept
>     getting errors when trying to add the tuner card. It could not ID
>     the card but obviously could find it in a scan of tuners.
>     I have not powered off the system, but I have rebooted several times.
>     Has there been any recent changes to how the tuner cards are
>     initialized at boot? This system has been running without major
>     changes for a couple of years.
>     Jim A
> Some additional information.  I powered off the system and restarted 
> and nothing changed over just resetting as expected.  I temporarily 
> added some HDHomerun tuners to get the morning recordings to happen.  
>  Now that that is over, I tried deleting all tuners and adding back in 
> the Hauppauge WinTV QuadHD card.  If find the tuner but when I look at 
> the parameters of the tuner I see:
> Frontend ID   Could Not get Card info for /dev/dvb/adapter0/frontend0
> At the bottom of the screen I see "appears the card can be in use by 
> another program."
> I have not installed any new software on the system so not sure what 
> this could be all about.
> Jim A

ls -l /dev/dvb/adapter0/frontend0

You should see this

crw-rw----+ 1 root video 212, 3 Nov  8 08:59 /dev/dvb/adapter0/frontend0

Make sure it shows group video and also make sure the user id that runs 
mythbackend and the one that runs mythfrontend have the video group (run 
-i -a while logged into those users).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20221108/668f4087/attachment.htm>

More information about the mythtv-users mailing list