[mythtv-users] StreamZap/LIRC stopped working

Gary Raposo gary at raposo.ca
Sat Jun 4 03:30:33 UTC 2022

Hello all,

I know this issue isn't directly related to MythTV but I'm hoping 
someone on the list with the same hardware and OS could help me 
troubleshoot this issue.

I've been using a StreamZap remote and USB IR receiver to control MythTV 
via LIRC for years. It hasn't really given me any problems. A recent 
Fedora 35 update broke things. LIRC is not registering any key presses 
even though I can see the red indicator on the IR receiver blink every 
time I press a button on the remote. I can't pinpoint the exact update 
that broke things because it took me a while to notice the remote wasn't 

Right now I'm running Fedora 35 (5.17.11-200.fc35.x86_64) with 
lirc-core-0.10.0-32.fc35.x86_64 on my combined MythTV FE/BE.

If I stop lircd and run mode2, I can see all the key presses. If I start 
lircd and run irw, I see nothing. No errors are logged - everything 
appears to be running properly.

I've uninstalled and reinstalled LIRC. It's a pretty simply set up:

- lsusb shows: Bus 001 Device 006: ID 0e9c:0000 Streamzap, Inc. 
Streamzap Remote Control
- streamzap and rc_streamzap modules are loaded load
- /etc/lirc/lirc_options.conf is stock except for two changes:
    driver = default
    device = /dev/lirc0
- /etc/lirc/lircd.conf.d/streamzap.lircd.conf was created using the 
config found here: 

Using driver default on device /dev/lirc0
Trying device: /dev/lirc0
Using device: /dev/lirc0
Warning: Running as root.
(codes displayed with each key press)

systemctl start lircd (starts successfully with no errors)


I've gone over /etc/lirc/lircd.conf.d/streamzap.lircd.conf with a fine 
tooth comb and there's nothing wrong with it. It's worked for me for 
years and it's the same as others that I've found with a bit of Googling.

I installed a fresh copy of Fedora 36 on a different machine and moved 
the USB IR receiver over. I configured it exactly as above - same 
outcome, mode2 looks normal but nothing out of irw,

I then moved the USB IR receiver over to a Raspberry Pi (Linux 
RaspberryPi 5.15.32-v7+), installed LIRC, and applied the same 
configuration as above and it worked. So I know the USB IR receiver and 
remote control are fine.

Has anyone seen this behaviour with StreamZap+LIRC on Fedora? Any hints 
on how to fix or even troubleshoot this one?



More information about the mythtv-users mailing list