[mythtv-users] Myth 031 RPMFusion what to do about MySQL/MariaDB

Ken Smith kens at kensnet.org
Mon Sep 6 15:53:07 UTC 2021

John Pilkington wrote:
> On 03/09/2021 17:37, John Pilkington wrote:
>> On 03/09/2021 16:45, Ken Smith via mythtv-users wrote:
>>> Hi everyone,
>>> I'm attempting to set up a new Myth system on AlmaLinux (A RHEL 8 
>>> clone). I'm getting errors like this from DNF
>>>   Problem 1: package 
>>> mythtv-31.0-19.158.20210629git0680b37c68.el8.x86_64 requires 
>>> mariadb, but none of the providers can be installed
>>>    - package mariadb-3:10.3.28-1.module_el8.3.0+2177+7adc332a.x86_64 
>>> conflicts with mysql provided by 
>>> mysql-8.0.21-1.module_el8.3.0+2049+47abd494.x86_64
>>>    - package mysql-8.0.21-1.module_el8.3.0+2049+47abd494.x86_64 
>>> conflicts with mariadb provided by 
>>> mariadb-3:10.3.28-1.module_el8.3.0+2177+7adc332a.x86_64
>>>    - package 
>>> mythtv-frontend-31.0-19.158.20210629git0680b37c68.el8.x86_64 
>>> requires mysql(x86-64) >= 5, but none of the providers can be installed
>>>    - conflicting requests
>>>    - package mariadb-3:10.5.9-1.module_el8.4.0+2357+88cd7ba1.x86_64 
>>> is filtered out by modular filtering
>>> I only have mariadb on the machine at the moment.
>>> I don't understand why its saying that the frontend needs mysql?
>>> I have EPEL and RPMFusion repo's configured.
>>> It seems that both mysql and mariadb are in Alma's Appstream repo.
>>> If I'm reading it right, the spec file appears to require a few of 
>>> the mysql modules.
>>> Any suggestions most welcome.
>>> Thanks
>>> Ken
>> I haven't tried tried an el8 clone yet, but what happens with
>> 'dnf install mythtv --allowerasing'  ?
> More to the point:  https://access.redhat.com/discussions/5367271
> RHEL8: mariadb-libs filtered out by modular filtering
> but that needs a changed specfile.  Maybe
> https://unix.stackexchange.com/questions/644322/libssh2-filtered-out-by-modular-filtering-on-rhel-8 
> would help.
> John P
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org
Hi All,

After installing a few dependencies manually I did this...

dnf -v install  mythtv mythtv-backend mythtv-base-themes mythtv-common 
mythtv-docs mythtv-libs mythtv-setup perl-MythTV php-MythTV 
python3-MythTV mytharchive.x86_64 mythbrowser.x86_64 mythffmpeg.x86_64 
mythmusic.x86_64 mythnews.x86_64 mythplugins.x86_64 mythweather.x86_64 
mythweb.noarch mythtv-frontend --allowerasing --best --skip-broken

Everything was installed except two key packages with this error message 
at the end of the install


I then tried this

dnf install  mythtv mythtv-frontend --allowerasing --disablerepo=appstream

Last metadata expiration check: 1:00:28 ago on Mon 06 Sep 2021 15:38:05 BST.
  Problem 1: conflicting requests
   - nothing provides perl(JSON) needed by 
   - nothing provides perl(XML::XPath) needed by 
  Problem 2: conflicting requests
   - nothing provides mysql(x86-64) >= 5 needed by 
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' 
to use not only best candidate packages)

I could manually install the two perl packages, and force the rest of 
the installation. But this is getting really messy, but I guess its to 
do with how dnf sorts out the versioning between mysql and mariadb

Anyone with far greater insight into dnf able to offer some guidance.



This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the mythtv-users mailing list