[mythtv-users] Can't connect to remote backend database (again)

Stephen Worthington stephen_agent at jsw.gen.nz
Mon Sep 6 05:43:59 UTC 2021

On Sat, 4 Sep 2021 17:34:58 +1000, you wrote:

>> >Could you please advise how I can change the MySQL settings to accept
>> older
>> >auth methods?
>> It looks like you need to do this to the MySQL server config:
>> [mysqld]
>> default_authentication_plugin=mysql_native_password
>> I am running MariaDB these days, so I can not test that setting, but I
>> think all you need to do is to put those lines in a new file in
>> /etc/mysql/conf.d.  Call it "old_auth.cnf" for example.  The file
>> should be "chown root:root" and "chmod u=rw,g=r,o=r".  Then restart
>> mysqld:
>> sudo systemctl restart mysqld
>> This problem should only have happened if you have installed MySQL
>> version >=8 and then created users for MythTV.  If you created the
>> MySQL users for MythTV on an older version of MySQL and then upgraded
>> MySQL to v8 it should have retained the older auth settings for all
>> the existing users.
>> It should also be possible to change the auth setting per user back to
>> the old method:
>> ALTER USER <user>
>>   IDENTIFIED WITH mysql_native_password
>>   BY '<password>';
>> You may need to do the ALTER USER command or delete and re-create the
>> user for the CGTV device even though you have added that config file
>> as new users created on v8+ get the then current default
>> authentication setting, which was "caching_sha2_password" at the time
>> that user was created.
>Thanks Stephen. I tried what you suggested and changed the MySQL settings
>but the Chomecast with Google TV still wouldn't connect. So I dropped the
>user account in MySQL and re-created it. Still no joy - even though the PC
>sitting right next to it on the same subnet connects without problems.
>I also contacted the developer of the mythtvfrontend Android app and
>relayed your theory to him. He was very helpful and tried installing and
>connecting and it all worked fine for him. After his testing he said "So it
>is not an incompatibility with mysql or with recent versions that is
>causing the problem".
>I've also tried to install a MySQL client on the device. But there's only
>one I could find, and it doesn't work on Google TV because the UI won't let
>you create a connection database using a remote control. The developer is
>going to address that in the next release but I have no idea when that will
>So I'm now even more stumped than I was before.

If you capture the TCP/IP packets again, is it the same as before - is
it still the same error message?

More information about the mythtv-users mailing list