[mythtv-users] Help with playback issue on recordings from a single channel

Vincent Poore vincepoore at yahoo.com
Thu Dec 30 00:08:27 UTC 2021


 Thanks Barry
I have an AMD A10-5800K APU 3.8Ghz 4 Core Processor with integrated Trinity Radeon HD 7660D graphics.
I'm running Ubuntu 20.04 which has AMDGPU open source drivers to support both VDPAU and VAAPI acceleration protocols.
I might try VAAPI to see what happens but my experience also matches Don Brett's advice in that it plays perfectly in Open GL.   Thanks for sharing that insight.

    On Wednesday, December 29, 2021, 08:13:57 AM MST, Barry Martin <barry3martin at gmail.com> wrote:  
 
   

 
 
Vincent:
 
   
 I've been living with and frustrated by a problem with recordings from 
my local CBS broadcast channel.

It all started when my local station added a new digital sub-channel.  
 I know this because my problem started on March 1st and a call to the 
station engineer confirmed changes were made to the broadcast signal 
early that Sunday morning. He says, "Everything in this encoding scheme 
is industry standard, so I wouldn't expect there to be any problem 
decoding it with commercial equipment." I'm not technical enough to 
determine what has changed that would give mythtv so much trouble. 
 
It appears the CBS network does a few things differently from other networks.  Not necessarily wrong, just different.  With the local CBS channel and watching via television (not via MythTV) if the Closed Captioning is set for one of the settings other than CC1 (I've forgotten which one) a big black box will overlay most of the screen.  This does not occur with any of the other networks/stations (I tested for 'fun').
 
Not really of any specific help but I'm wondering if perhaps you have a Closed Captioning option set?  The overlay does not appear on all CBS programmes.
 
Also, IIRC VDPAU is for nVidia video cards -- so check correct and up-to-date.  Also found this old note which could explain your VDPAU issues:
 
<start quote>
 
 
 
 
 
 7. Re: HD Hiomerun works better in HDHomeRun viewer than MythTV (Don Brett)
 

 
 
 
 
|  
Subject: Re: [mythtv-users] HD Hiomerun works better in HDHomeRun viewer than MythTV
  |
|  
From: Don Brett <dlbrett at zoominternet.net>
  |
|  
Date: 1/25/19, 11:17
  |

 
 
 
|  

 
  |

 
There is a bug with VDPAU rendering. Certain channels in the USA are using MPEG2 in a way that overloads VDPAU and causes pixellation every few seconds. This is nothing to do with HDHomerun, it happens with any type of equipment. The solution is to change to software decode and OpenGL Rendering for mpeg2 streams. If you are not using VDPAU ignore this email. 
 Peter 
 

 
 

 
 

 
 
 
 
|  
Subject: Re: [mythtv-users] HD Hiomerun works better in HDHomeRun viewer than MythTV
  |
|  
From: Peter Bennett <pb.mythtv at gmail.com>
  |
|  
Date: 1/25/19, 11:48
  |

 
 
 
|  

 
  |

 
I suggest change your profile to one of the OpenGL ones (try OpenGL Slim) instead of "VDPAU High quality". If that solves your problem you can customize a profile that uses OpenGL for mpeg2 and OpenGL for others, or you can just leave it using OpenGL Slim. 
 
 
 
 

 Mythfrontend > Setup > Video > Playback (3/8):  
 

 
 
 
 
 
|  
Subject: Re: [mythtv-users] HD Hiomerun works better in HDHomeRun viewer than MythTV
  |
|  
From: Don Brett <dlbrett at zoominternet.net>
  |
|  
Date: 1/25/19, 14:24
  |

 
 
 
|  

 
  |

 
Just tried it, but when I played an existing recording, the audio played and mythfrontend exited to the desktop...audio continued to play until I rebooted.  Is there a library I need to install? 
 
 
 
 
 
 
 
 
 
|  
Subject: Re: [mythtv-users] HD Hiomerun works better in HDHomeRun viewer than MythTV
  |
|  
From: Peter Bennett <pb.mythtv at gmail.com>
  |
|  
Date: 1/25/19, 14:41
  |

 
 
 
|  

 
  |

 
Make sure that the Theme Painter is set to opengl2 in Settings->Appearance. If that does not work you may have a broken opengl system. 
 
 
<end quote>
 
 
Barry
 
 

 
 
 
 

 
 

 
 

 
 

 
 _______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org
http://lists.mythtv.org/mailman/listinfo/mythtv-users
http://wiki.mythtv.org/Mailing_List_etiquette
MythTV Forums: https://forum.mythtv.org
  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20211230/cedf7072/attachment.htm>


More information about the mythtv-users mailing list