[mythtv-users] Build from source on Archlinux -Master

James Abernathy jfabernathy at gmail.com
Wed Dec 29 21:44:38 UTC 2021


On Wed, Dec 29, 2021 at 4:33 PM Roland Ernst <rcrernst at gmail.com> wrote:

>
>
> On Wed, Dec 29, 2021 at 10:12 PM James Abernathy <jfabernathy at gmail.com>
> wrote:
>
>> Just a quick update.  I did a make clean my way by deleting the whole
>> build folder and re-cloned mythtv. I also did "pacman -S python-pip"
>>
>> At this point the console log capture is way bigger than the last run and
>> I see several mentions of mythpython in the output.
>>
>> So maybe it's fixed.
>> BTW, I could not get ansible to work for Archlinux. So it's a lot of
>> trial and error.
>>
>> Jim A
>>
>>
> Jim
> Interesting. And thanks for the update.
> As long as you can install the latest MythTV python bindings, this is
> solved on your side.
>
> But: On Arch Linux, the package "python-setuptools" depends on
> "python-pip".
> But this package could be out-dated.
> Did you a fresh install of Arch Linux ?
>
> Roland
>

Yes, the Archlinux was installed fresh this morning just to experiment with
mythtv on Arch. I'm trying to create a PKGBUILD for mythtv that tracks
master instead of the one that just tracks v31. It's something to keep me
busy until the drinking lamp is lit.

The build after the python-pip install worked. Now I'm down to fixing the
library links. I'm getting the usually:
error while loading shared libraries: libmythtv-32.so.32: cannot open
shared object file
I think I know how to fix that for the Building from source wiki.

Thanks again.

Jim A
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20211229/c19054fd/attachment-0001.htm>


More information about the mythtv-users mailing list