[mythtv-users] Mythbuntu upgrade error - mysql8

John Hoyt john.hoyt at gmail.com
Sat Dec 11 20:29:47 UTC 2021


>
>
> You could do the grep --recursive plugin /etc/mysql and see if a plugin_dir
> exists. Then look under there for a component_validate_password file. Or
>
>   sudo locate component_validate

to see if it shows up. It doesn't on my host, which makes sense since
> I don't have the failure or the settings.
>
>
 yep - there it is:

# sudo locate component_validate
/usr/lib/mysql/plugin/component_validate_password.so

This is a possible reason: https://graspingtech.com/install-mysql-ubuntu/
> Look for VALIDATE PASSWORD about midway down the page and see if it rings
> any
> bells with you.
>

Yep - I completely forgot that I did this a while ago in an attempt to
improve security


> There may be other things that cause the password to fail, try: SHOW
> VARIABLES LIKE 'validate_pass%';
> Details here:
> https://dev.mysql.com/doc/refman/8.0/en/validate-password-options-variables.html
> "mythtv" is shorter than 8 in the example etc.
>

I managed to set global "validate_password.length" to 6 and I think it
resolved my issue.

Bill - as always, thank you very much for the help!!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20211211/69bf328d/attachment.htm>


More information about the mythtv-users mailing list