[mythtv-users] Can't connect to remote backend database (again)

Stephen Worthington stephen_agent at jsw.gen.nz
Sun Aug 15 06:48:07 UTC 2021

On Sun, 15 Aug 2021 15:19:08 +1000, you wrote:

>I've been trying everything to get mythfrontend Android app to connect
>from  a Chromecast with Google TV but still no luck. So yesterday I factory
>reset the Android TV and re-installed all the apps. Still no luck and
>there's some weird stuff:
>   1. After doing a factory reset and re-installing mythfrontend, the
>   settings displayed a username and password without me putting them in yet.
>   How can that possibly happen if this is the first run after a factory
>   reset? There should be no historic settings, like a password, to be picked
>   up
>   2. I can telnet mbe4 3306 from an SSH app on Android TV and it seems
>   that a connection attempt is made. I also enabled MySQL general-log=1 so
>   I could see what happens when a connection attempt is made from
>   mythfrontend on Android TV, but nothing appears in the
>   /var/lib/mysql/MBE4.log for it so that's weird.
>   3. I created a new mythtv account (creatively named mythtv2) and granted
>   privileges to it but this can't connect either.
>   4. When the app is trying to connect it says "Waiting for database to
>   start". Is that normal given that this is an Android app so the database is
>   on a remote backend? Is it just a poorly worded message, or is it actually
>   looking for a database on the Android TV device (where it won't find one)?
>So the way I read the situation is that connectivity appears to be OK but
>it can't connect to the remote database. For some reason. Best known to
>itself. I wonder if I've stuffed something up in the area of database users
>and grants. Here's my user accounts from MySQL showing 2 accounts for
> which is my Android TV device:
>| host          | user             | authentication_string
>                                 |
>| %             | mythtv           |
>*E9333A4FFE29CF0081729D3EB885F8EABCD47CBA                              |
>| 192.168.0.%   | mythtv           |
>$A$005$Oj"_1AmjRHKwT#:qZeMYiDQ5wgXeZoLjQ4.fC2CcLwjBaj8jmz.lAYlpI8. |
>| | mythtv           | $A$005$
>R7DD?CM27zLrb!NK/KA7CtGy4tPU3ED7HrPYKuxpxUQroYfApmeksZfwh9 |
>| | mythtv2          |
>$A$005$+_B0pk(9x+rre!*XHmcl/uazRoEn/rbsd6cAodYWCTK40TzRtuRwd9xdm9A |
>| localhost     | debian-sys-maint | $A$005$T
>                                             +  P\      2{(+p`*I
>7GEo9iwbghOjnQvXKm2gZ0VUY/nhHCi38.1baiu6po4 |
>| localhost     | mysql.infoschema |
>| localhost     | mysql.session    |
>| localhost     | mysql.sys        |
>| localhost     | root             |
>*58D540776DD45547773EC3D627954E383D1A9ABA                              |
>I'm out of ideas for how to make this work. I've been a mythtv user
>since 2004 but this has me totally stumped. Any ideas would be very, very

Run Wireshark or tshark or tcpdump on the backend box and capture the
traffic from the Chromecast with Google TV and see if it is actually
ever trying to connect to the database.  Just use a "host" capture filter to only see the traffic from the
Chromecast with Google TV.

More information about the mythtv-users mailing list