[mythtv-users] mythtranscode crashes on a .ts HD file

Stefan Davids mythtv at stefan.davids.uk.net
Sun Jan 13 17:44:34 UTC 2019


On 13/01/2019 17:14, UB40D wrote:
> 
> 
> On Sun, 13 Jan 2019 at 15:43, John Pilkington <johnpilk222 at gmail.com 
> <mailto:johnpilk222 at gmail.com>> wrote:
> 
>     *lossless* transcode is great for removing commercials,
>     whilst still keeping the broadcast quality.
> 
>     However currently only works for mpeg2 content and not
>     the newer formats which HD tends to be broadcast in
> 
> 
> That's very much a pity; but what I posted seems to indicate that 
> mythtranscode doesn't work on HD even with LOSSY transcoding. When I 
> removed the --mpeg2 option it still didn't work. Although it gave hope 
> that it might work if one could somehow install some H.264 profile from 
> somewhere...

To use mythtranscode on h264 with a cutlist you need to use it in fifo 
mode to output raw video which can then be transcoded by ffmpeg or 
similar reading from the fifos.  Or generate the cutlist via mythutil 
and just use ffmpeg directly to cut out those bits and concatenate it 
together.

If you're familar with perl there's an example I use here at
http://git.netscum.org.uk/stefan/h264_fifo/src/master/transcode_perl or 
there are many other examples in shell script or python around (at least 
two on the mythtv website).

It seems almost impossible to get the cutting exactly right though for 
h264 though.

Stefan


More information about the mythtv-users mailing list