[mythtv-users] Recording failure.

Allen Edwards allen.p.edwards at gmail.com
Wed Feb 20 18:18:53 UTC 2019


On Fri, Feb 15, 2019 at 9:31 PM Allen Edwards <allen.p.edwards at gmail.com>
wrote:

> This happened again today. I was able to do some experiments this time so
> I have new data.
>
> I ran the HDHomerun_Config gui and both HDHomerun devices were missing.  I
> power cycled the HDHomerun units and no difference.  I also ran
> <hdhomerun_config 10137DC1 set /ir/target "192.168.1.111:5000 no_clear">
> before and after power cycling the HDHomerun units and linux just gave an
> error message <unable to connect to device>. This is the command I use in
> rc.local to configure the units on power up. Power cycling the mythbox
> without power cycling of the HDHomerun boxes fixed the issue.
>
> I noticed this evening because the remote would not work (the HDHomerun
> has the ir reader).  We went ahead and watched our evening show without
> issue using a keyboard for control. Then I ran my tests after we were done
> watching.
>
> I also noticed that our 3PM show did not record but the 8AM show did
> record. The 3PM show comes on again at 6PM and myth tried to record it both
> times but failed.
>
> This sure looks like something new to Mythbuntu 16.04.1 LTS. I ran the
> same hardware with Mythbuntu 8 for ten years without this happening.  It
> seems to happen not quite once a month and the unit is on 24/7.
>
> Any ideas?  I don't know what to do.
>
>
This is an update.  I think the consensus is that this is a network
problem. I got the suggestion from Silicondust that I see if the HDHomeRun
units are visible from my Windows computer on the same network.  I also set
the IP addresses as reserved in case it is a router problem although that
seems very unlikely. At this point I am going to wait and see if it happens
again and them do some troubleshooting.

I guess there is a legitimate question if the drivers on Mythbuntu 16 could
be incompatible with my old motherboard.  I never had this problem with
Mythbuntu 8 which I ran on the same hardware for many years. Something like
this happened on my video card drivers causing many hours of
troubleshooting and way more learning about video drivers than I expected
to need.

Should be using a different network driver?

Here is some information from lspci -v

02:00.0 Ethernet controller: Qualcomm Atheros Attansic L1 Gigabit Ethernet
(rev b0)
        Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Memory at febc0000 (64-bit, non-prefetchable) [size=256K]
        Expansion ROM at feba0000 [disabled] [size=128K]
        Capabilities: [40] Power Management version 2
        Capabilities: [48] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [58] Express Endpoint, MSI 00
        Capabilities: [6c] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Kernel driver in use: atl1
        Kernel modules: atl1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190220/36e9d764/attachment.html>


More information about the mythtv-users mailing list