[mythtv-users] Recording failure.

Allen Edwards allen.p.edwards at gmail.com
Sat Feb 16 05:31:59 UTC 2019


This happened again today. I was able to do some experiments this time so I
have new data.

I ran the HDHomerun_Config gui and both HDHomerun devices were missing.  I
power cycled the HDHomerun units and no difference.  I also ran
<hdhomerun_config 10137DC1 set /ir/target "192.168.1.111:5000 no_clear">
before and after power cycling the HDHomerun units and linux just gave an
error message <unable to connect to device>. This is the command I use in
rc.local to configure the units on power up. Power cycling the mythbox
without power cycling of the HDHomerun boxes fixed the issue.

I noticed this evening because the remote would not work (the HDHomerun has
the ir reader).  We went ahead and watched our evening show without issue
using a keyboard for control. Then I ran my tests after we were done
watching.

I also noticed that our 3PM show did not record but the 8AM show did
record. The 3PM show comes on again at 6PM and myth tried to record it both
times but failed.

This sure looks like something new to Mythbuntu 16.04.1 LTS. I ran the same
hardware with Mythbuntu 8 for ten years without this happening.  It seems
to happen not quite once a month and the unit is on 24/7.

Any ideas?  I don't know what to do.

Allen



On Mon, Jan 21, 2019 at 10:34 PM Allen Edwards <allen.p.edwards at gmail.com>
wrote:

>
>
> On Fri, Jan 18, 2019 at 7:20 AM Jan Ceuleers <jan.ceuleers at gmail.com>
> wrote:
>
>> On 18/01/2019 05:17, Stephen Worthington wrote:
>> > The biggest problem with using re.local is that any command that fails
>> > instantly terminates rc.local - no further commands are executed.  So
>> > doing a series of commands as you are in rc.local is not a good idea.
>> > It is much better to get rc.local to run a separate script.  So you
>> > would put your commands in a script such as
>> > /usr/local/bin/start-hdhrs.sh, and then run that from rc.local like
>> > this:
>>
>> A simpler solution, if rc.local's termination behaviour is not desired,
>> is to change it. Simply remove the "-e" from the first line in the
>> script so that /bin/sh is not called with the -e parameter.
>> _______________________________________________
>>
>
> rc.local runs fine.  It is just that the HDHR which is initialized by
> rc.local quit responding.  I never turn my system off so I would say that
> the HDHR was probably running for several months before it suddenly became
> unresponsive. The strange thing is that the last time it happened, it was
> at about the same time of day thus missing one show late at night and the
> show the next morning before it was discovered.
>
> That said, I did notice the behavior in rc.local where if there is an
> error it terminates. If I ever change it, I run it from the command line
> where I can see the error messages.
>
> Allen
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20190215/23ad6996/attachment.html>


More information about the mythtv-users mailing list