[mythtv-users] rpm build of master: sudden new failure

John Pilkington johnpilk222 at gmail.com
Tue Aug 6 10:44:27 UTC 2019

On 04/08/2019 23:20, Bill Meek wrote:
> On 8/4/19 4:04 PM, John Pilkington wrote:
>> Last week (and several times in the past month) I built rpms for 
>> master for both Fedora 29 and el7.  The builds were done in F29 using 
>> Gary B's script with my normal dropping of libvpx for el7, and both 
>> mythtv systems are running well.
>> Now, two commits later, the build fails.  The apparent reason is 'No 
>> space on device.'  This is presumably /tmp, which shows as 2 GB; 
>> system RAM is 4 GB.  I tried a google-suggested mount -o increase to 4 
>> GB, and also tried reverting to kernel 5.1.18 but still see the same 
>> problem. ubuntu PPA shows a build at the same commit.

> The MythTV buildbot just completed builds on: master-f29-64bit and 
> master-f28-64bit
> a few minutes ago (and roughly 100 prior to that.) It doesn't appear to 
> be a commit
> issue.
> *buntu user here, so I don't know if Fedora's /var/tmp is a link to 
> /tmp, but /var/tmp
> appears to be where the space issue is. df --si /var/tmp. I read the 
> comment to be
> about btrfs only, not including /var/tmp

The 'mock' wiki reveals that the default builddir is /var/lib/mock - and 
says 'make sure you have enough room.'

I had old builds in there.  I don't know what else is taking up space in 
that LVM volume, but I've deleted the old builds and started a new one...


The new builds (3a918bd) for F29 and el7 completed, installed and are 
running.  After each build the script automatically clears 
/var/lib/mock, and 'df -h /var/lib/mock' now shows 13 of 50 GiB available.

The relics that caused the problem were probably from builds that had 
been forcibly stopped.

And the new channel-scan output?  Very pretty, but boring.  No actual 
channel changes seen :-)


More information about the mythtv-users mailing list