[mythtv-users] Database fails to upgrade

David Highley dhighley at highley-recommended.com
Sun Oct 15 04:16:08 UTC 2017


After upgrading to Mythtv version 29 via rpmfusion packages for Fedora
the backend will not run because the database upgrade is failing with a
log message about invalid sql. From the log file below:

2017-10-13 03:45:08.076380 C [16990/16990] CoreContext dbcheck.cpp:437 (performActualUpdate) - Upgrading to MythTV schema version 1347
2017-10-13 03:45:08.076484 E [16990/16990] CoreContext dbcheck.cpp:411 (performUpdateSeries) - DB Error (Performing database upgrade):
Query was: @�^F^B
Error was: Driver error was [2/1064]:
QMYSQL: Unable to execute query
Database error was:
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '@�^F^B' at line 1

2017-10-13 03:45:08.076490 E [16990/16990] CoreContext dbcheck.cpp:519 (UpgradeTVDatabaseSchema) - Database schema upgrade failed.
2017-10-13 03:45:08.076671 E [16990/16990] CoreContext main_helpers.cpp:571 (run_backend) - Couldn't upgrade database to new schema


More information about the mythtv-users mailing list