[mythtv-users] Verizon Fios QIP7100 2 occasionally turns itself off, 6200ch always thinks it's on

Will Dormann wdormann at gmail.com
Wed Jun 29 12:11:31 UTC 2016

I'll combine multiple responses here,

> If you are using the same USB bus for both, consider moving one (or 
> the other) to another bus.  And then perhaps swap. And make sure the 
> HDPVR one is a USB 2 port (not USB 3).

The system actually only has one USB device:

$ lsusb
Bus 001 Device 002: ID 2040:4903 Hauppauge HS PVR
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

> Out of curiosity - how are you getting the HDPVR back to a working 
> state? Replug the USB or replug the power or something else? Do you 
> see anything of interest in 'top' while in a locked / unavailable 
> state? Or anything in 'dmesg'?Have you tried sending a usb software 
> reset to the device while in locked state to see if that kicks it 
> going again?

I've pressed the power button on the front of the device.  That turns it
off just fine.  I've tried various things when not there in person,
including rebooting the system.  When the host is rebooted and the
HD-PVR is in this state, it doesn't even recognize the HD-PVR at all.
lsusb shows nothing, and there is no /dev/video0.   MythTV loads up as
if the HDHR is the only available tuner, which actually isn't all that
terrible.   As soon as I power cycle via the power button on the front
of the hd-pvr, the mythtv box detects it and can use it.    At this
point I power cycled the whole mythtv box for good measure, though I
suppose just restarting mythbackend would have sufficed to get it to
pick up the new tuner.

> Could it be temperature related?  I know there were some hardware 
> revisions related to heat on these.  Mine are all running with the 
> covers removed and good air circulation.

I considered this and/or using a dedicated fan, based on other messages
I've seen.  But the box is in a temperature-controlled environment.  I
suppose that just taking off the cover could be a simple workaround if
that's sufficient without a fan.  Did you have heat issues before taking
off the covers, or is this intended to be a preventative measure?

> Additionally, when is the last time you connected these to a Windows
> PC to update their firmware?  AFAIK, it can only be done that way.
> If you never have, it may be worth doing.  You can see the firmware
> version in dmesg/syslog... but I don't recall what the most recent
> version is(according to what is reported there, which is different
> than the windows driver version).

I think I'm running the latest:

[   10.437400] hdpvr 1-6:1.0: firmware version 0x1e dated Mar  7 2012

As I'm going through my browser history, I see that I've already been to
<http://ubuntuforums.org/archive/index.php/t-2148605.html>, which maps
up firmware 0x1e to hdpvr_1.7.1.30059.

It could be that all along I've had a not 100% reliable HD-PVR, but
since enabling my hourly STB power check script, that guarantees that
the device will start recording something at least 24 times a day.   So
just by the numbers I'm more likely to encounter trouble.

Alternatively, it could be that said script triggers an unexpected use
case that puts it into an unexpected state:

dd if="$pvr" of="$out" bs=64K count=2  1>/dev/null 2>/dev/null

When recording a half-second or so of video 24 times a day, one of them
could trigger a bug in its state machine?  If so, perhaps increasing the
length of this periodic recording could avoid this?


More information about the mythtv-users mailing list