[mythtv-users] Myth Netvision audio not working

Don Brett dlbrett at zoominternet.net
Sun Mar 23 17:25:55 UTC 2014

I have a test box (latest MythBuntu installed (12.04.3) and I'm trying 
to get Myth Netvision to work on HDMI.  The video seems fine, and the 
audio works on some streams, but anything using Adobe flashplayer 
doesn't' work (using the Hulu.com site).  The Mythtv player works fine.

I ran across a troubleshooting tip that said to exit mythtv and get 
Chromium or Firefox to work; those also  have the same audio problem.  
I've searched and tried lots of solutions (asoundrc, asound.conf, 
alsamixer for mute, force reload, check plugins, etc, etc.).  The only 
success has been with aplay and VLC.

Anyone have suggestions on getting this to work?


PS - aplay was a bit odd; this command doesn't work at all:
don at zedo:~$ aplay -D hw:1,3 /usr/share/sounds/alsa/Front_Left.wav

...this works, but only on the second try (try command...nothing; try 
command again...works fine):
don at zedo:~$ aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Left.wav

...VLC didn't work until I changed it's output (start playing a clip, 
select audio > audio device > pick the HDMI device)

More information about the mythtv-users mailing list