[mythtv-users] Is there a way out of this tar pit?

Stephen P. Villano stephen.p.villano at gmail.com
Sun Mar 23 04:51:16 UTC 2014

On 3/22/14, 11:56 PM, John J Tucker wrote:
> Greetings,
> I am really struggling to find a solution and I'm tired and out of ideas.  First, I have been running Mythtv for about 7 years since .21 I think. I have been using Mythbuntu mostly.  I month or two ago I started having problems and I thought that an upgrade to ubuntu might be the answer. I was running myth .27 and ubuntu (some version that would not upgrade to 12.10, I remember that I had to upgrade to 12.04 first and then 12.10)  The trouble stated there.  The upgrade failed and the FE/BE would no longer boot.  I thought OK, all of the important files are on separate disks and the boot disk only contains ubuntu and mythtv and I have backups of the important config files (etc/fstab, avahi configs, netatalk...) so all I had to do was install ubuntu 12.10 from the ISO's dl from the ubuntu web site. Well these ISOs will not boot, some nonsense about not finding a live file system.  I google'd the exact error and most of the results were many years old and the remedy was to switc
>  h the master/slave jumpers on the IDE HD/DVD drives.  I found this to make no sense at all and it did not fix the problem.  I got fed up with ubuntu and while IDE is legacy hardware, that is what I have and it has worked fairly well.  I have a small IDE HD and all of the big storage drives (2x3TB + 8TB RAID) are SATA and I don't care if they even show up during the install because I have to add gparted, xfs file system support and edit fstab before they are usable.
> I switched to Debian wheezy and found it lacking in many ways.  The packages I was interested in were not current and I don't know enough about Debian ways to hook-up the versions I wanted/needed.  My Mythtv database was .27 and the debian multimedia sources had .25. I don't know what headaches were inflicted by attempting to go back with the database.  I downloaded Mythtv .27 source and compiled it and restored the database and was about to start configuring the BE.  I was also intrested in pulseaudio and found the current version is 5 and debian had version 2 installed.  VLC presented an error stating that pulseaudio version 2 had to much latency and suggested updating to version 3. I attempted to compile pulseaudio and there was no end to the pain.  No documentation as to how to run configure and multiple errors with missing this and missing that. So after about five fix this, add this lib I completed the configure, make and make install.  I then attempted pulseaudio --ver
>  sion and some lib is missing.
> So, is there some other linux distro that I can build Mythtv .27 and pulseaudio 3+.  I would prefer prebuilt binary packages but if the source packages have adequate documentation, I'm OK with that.
> Thanks for any and all advice.
> adios,
> jt
> _______________________________________________
First, the way out of a problem that is ongoing is not *usually*
upgrading. Fix the problem, *then* upgrade.
If I had a damaged active directory in NT4 and tried to upgrade to W2K
or later, I'd be SOL in spades and massively break an entire domain. The
same is true with any database.

So, how to figure out the problem?
First, what was the error you had? Trying to reverse-engineer your
problem based upon the improper solution isn't the way to proceed.

I'll not even go into pulseaudio, the last time I was working with Linux
when I needed audio, we were pure alsa. Speedbump, proceed and learn.  :)
As I did have audio problems twice, it was a learning experience, but
the learning curve wasn't that sharp.

Going to Debian is not the best notion when moving from Ubuntu. Might as
well try going to Redhat after using CentrOs. No, that would turn out
slightly better.

Now, for me, I started with Mythbuntu at 0.25, screwed up the BE,
switched an old server (was itching to anyway) from W2k3 to Mythbuntu
and eventually fixed the old BE, made it a slave (it uses IDE boot and
primary drives, with a larger software RAID striped array for storage).
I'm also running two experimental boxes with the upcoming release of
Ubuntu, with only a few hiccups. OK, one needed a second try at install,
but it was alpha a the time.

Me? I'm experimental in a test group, I'm pure stable base in the
operational network. I'm that way when at work, I'm that way at home.

So, state your original problem in concise details. State your current
It's likely that Mythbuntu will work, with some "massaging". Due to the
current mess, it's likely that it'll be massive amounts of massaging.

If I sound a bit short, sorry. It's late and I'm rather tired. We all
would be happy to help you, with specifics on your problems.

More information about the mythtv-users mailing list