[mythtv-users] Frontend MySQL connection not working

Phill Edwards philledwards at gmail.com
Sun Mar 9 06:48:44 UTC 2014

I've been fiddling around with things on my home LAN and got into a
situation where my Frontend kept having connection errors with the separate
Backend. Once I'd got things back to the way they were on the LAN, I could
still no longer get a connection. So I tried to telnet to backend port 3306
from the frontend and got this error:

$ telnet 3306
Connected to
Escape character is '^]'.
hHost 'mfe1.local' is blocked because of many connection errors; unblock
with 'mysqladmin flush-hosts'Connection closed by foreign host.

I then logged into mysql as root on the backend and issued" flush hosts"
command. But the frontend still can't connect to the backend, even though I
can now get a telnet connection on port 3306:

$ telnet 3306
Connected to
Escape character is '^]'.

I'm now in that eternal loop where the frontend asks for hostname, DB name,
DB user etc (the "Database Configuration" screens) but it can't connect
when you click the Finish button so it loops round again to have another go.

I would have thought if the telnet connection is working it would all be
OK. Any idea how I can resolve this?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20140309/05d4b7bd/attachment.html>

More information about the mythtv-users mailing list