[mythtv-users] mythbackend startscript broken on fedora 19

mythtvuser at vandrosthagen.net mythtvuser at vandrosthagen.net
Sun Mar 2 20:25:44 UTC 2014

Hi Rachard and all others..

First of all i want to thank you for your reply's.. To explain littlebit on my post before.

I use atrpms and yes the root script addaid in the rpm from atrpm is an old script aka installed in /etc/init.d. That script runs under root and usage the /var/lib/mythtv as config dir.. I tried to make it work to softlink home dirs of the user mythtv that was running ok. But nothing worked.

Until now that is..

Yes you guys are right you don't want to run mythbackend under root default. So softlinking etc and using that script is awefull.
But after installing the service file Richard provided everything worked like a charm. mythbackend is now running under mythtv user and is reading the right directory for config.

Thanks again guys for the help.

From: Richard Shaw [mailto:hobbes1069 at gmail.com]
To: Discussion about MythTV [mailto:mythtv-users at mythtv.org]
Sent: Sun, 02 Mar 2014 14:25:08 +0100
Subject: Re: [mythtv-users] mythbackend startscript broken on fedora 19

On Sun, Mar 2, 2014 at 6:13 AM,  <mythtvuser at vandrosthagen.net> wrote:
Secondly the script i use is still an old startupscript because fedora decided to go to services.. I was wondering does anybody have an working services startup script or has figured out how to get the mythbackend script to run?  

You didn't specify where your packages came from but since Fedora 18 I believe (although I maintain the RPM Fusion packages I've slept a few times since then) the packages have defaulted to using systemd for startup. It doesn't sounds like your using my packages so I would recommend you poke around:  


And look at the systemd startup file, mythbackend.service  

It more or less works out of the box for the packages I build but I would recommend reviewing is as there's a lot of comments in there including other ways of starting it up.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20140302/e91feb07/attachment.html>

More information about the mythtv-users mailing list