[mythtv-users] Displayed recording duration not updated after applying cutlist

John Pilkington J.Pilk at tesco.net
Tue Sep 4 13:06:00 UTC 2012

On 04/09/12 00:30, Richard wrote:
> On 04/09/12 00:48, John Pilkington wrote:
>> On 03/09/12 23:23, Michael T. Dean wrote:
>>> On 09/03/2012 05:19 PM, John Pilkington wrote:
>>>> This is new since upgrading to 0.25-fixes.  Because I use my own
>>>> scripts to do the cutting I shall have to try to fix it, but I'd like
>>>> a pointer to tell me where to look.
>>>> In playback mode hitting step-forward brings up a display of current
>>>> position and total duration;  that's what isn't being updated.
>>>> Stepping to the end in the editor shows the correct new duration.
>>>> The script I use clears the cutlist, rebuilds the seek table
>>>> (mythtranscode --mpeg2 --rebuild) and resets the file size.  Any idea
>>>> what else it needs to do now?
>>>> FWIW I'm using MythCenter-Wide.
>>> No idea, but in 0.25+, the file size should be updated automatically
>>> when you rebuild the seek table, so I'd recommend removing that part of
>>> your script.
>>> http://www.gossamer-threads.com/lists/mythtv/firehose/502777#502777
>>> Mike
>> Good, I'll try that.  I just tried reversing the order of rebuild and
>> clearcutlist, with no effect.  I'll look at using other rebuild options
>> too - but ISTR that there was talk of dropping some of them?  I'll hunt
>> around a bit more and maybe try another theme, too.
> It may well be the duration entry in recordedmarkup.  The entry with
> type==33 (MARK_DURATION_MS).
> There appear to be two different ways of updating the seek table.  One
> is using mythtranscode, the other is with mythcommflag --rebuild.  I use
> mythcommflag and that seems to update the recordedmarkup entry ok.
> I don't know what the difference is otherwise between the two different
> approaches.
> Some themes show the duration of each recording in the 'Watch
> Recordings' list (e.g. Steppes) but this is just the difference between
> the start and end times of the recording.  I ended up writing a script
> that would trim the start and end according to the cutlist, update the
> start and end times of the recording accordingly and also filter out any
> data stream from the recording, leaving all audio, video and subtitle
> stream untouched (as I understand it, this should directly using
> 'Recording profiles' but that never seemed to have any effect).
> Depending on the channel and the amount of data streamed, the final file
> is sometimes almost half the original size!
> Richard.

Yes, switching from mythtranscode --mpeg2 --rebuild to mythcommflag 
--rebuild --file has cured the duration problem as described above.  Now 
there seem to be others in resuming playback after entering the editor 
if I try to use it for skipping around in the processed file.  Sometimes 
it resumes as expected, sometimes it just quits.  I haven't got it 
sussed yet.  I tried swapping the order of the clearcutlist and rebuild 
calls but don't recollect seeing a difference. mythcommflag --rebuild 
complains about a broken pipe, too.  I think that's why I hadn't moved 
to it before.  And it seems that neither it nor the editor's 
clearcutlist action will consistently set the EOF as a skip point.

This isn't a gripe.  I like 0.25-fixes.


John P

More information about the mythtv-users mailing list