[mythtv-users] mythfilldatabase problems with 0.25

Scott Knight scott at scottknight.com
Fri Nov 9 18:26:57 UTC 2012

on 11/8/2012 11:53 AM Bill Meek carved the following into a picnic table:
> On 11/08/2012 08:28 AM, James Pifer wrote:
> > Since my update to mythtv 0.25 my mythfilldatabase process runs, but does not populate any data. I can see there are log files under
> > /var/log/mythtv and mythweb status page shows it runs every day. If I run mythfilldatabase from the command line, it works and I get updated
> > guide data. I did some quick searches but didn't find much, so sorry if this has been discussed before.
> >
> > I do see some errors like this, that I don't see when I run it manually:
> ...
> > 2012-11-07 15:45:22.996844 E [16389/16389] CoreContext datadirect.cpp:1186 (GrabData) - DataDirect: Failed to get data: Download error
> >
> > Any ideas?
> Hi;
> Yes. Please see what:ls -l  /tmp/mythtv_ddp_data  shows. If its not there, ignore
> the rest of this response.
> I'm guessing that the owner will be you (not mythtv) and the mode will be -rw-r--r--.
Thanks for that tidbit.  I was also having failures for quite a while.  
Mysteriously, the failures went away for a bit, then came back when I 
upgraded to 0.26.  Now that I have it working again, thanks to this 
advice, I am pretty sure I know what happened.  Too bad I didn't connect 
the dots much earlier since I have been running this manually (as root) 
every few days.

The mysterious part where it started working for a while was probably 
due to me trying the mount /tmp as a ramdrive thing.  That was 
unsuccessful in itself, but in the process of doing that, I must have 
done some cleanup of /tmp which in turn allowed the mythtv user to write 
the temp file.

I see a couple of parts to a long term solution for this:

First, a more appropriate error message would help immensely. "Download 
error" leads to running down the wrong path since this is clearly a 
"Failed to create temporary file /tmp/mythtv_ddp_data" error.  There was 
no indication in the logs that it was even trying to create this file.

Secondly, why not just delete the file when finished by default? Provide 
an argument that prevents the deletion, but I see no need to keep it 
around unless debugging.

Maybe this is a good chance for me to get started pitching in on 


More information about the mythtv-users mailing list