[mythtv-users] mythfilldatabase problems with 0.25

Bill Meek keemllib at gmail.com
Thu Nov 8 16:53:02 UTC 2012

On 11/08/2012 08:28 AM, James Pifer wrote:
> Since my update to mythtv 0.25 my mythfilldatabase process runs, but does not populate any data. I can see there are log files under
> /var/log/mythtv and mythweb status page shows it runs every day. If I run mythfilldatabase from the command line, it works and I get updated
> guide data. I did some quick searches but didn't find much, so sorry if this has been discussed before.
> I do see some errors like this, that I don't see when I run it manually:
> 2012-11-07 15:45:22.996844 E [16389/16389] CoreContext datadirect.cpp:1186 (GrabData) - DataDirect: Failed to get data: Download error
> Any ideas?


Yes. Please see what:ls -l  /tmp/mythtv_ddp_data  shows. If its not there, ignore
the rest of this response.

I'm guessing that the owner will be you (not mythtv) and the mode will be -rw-r--r--.

If that's the case, take a look at: http://code.mythtv.org/trac/ticket/11195.

As long as I'm guessing, it could be that you ran mythfilldatabase as yourself from
the command line before housekeeping ran it from mythbackend. This also assumes that
you don't shutdown your backend, as that would blow away the file in /tmp.


More information about the mythtv-users mailing list