[mythtv-users] Error: offset>181?

Martin Moores moores.martin at gmail.com
Sun Nov 4 09:24:07 UTC 2012

On 4 November 2012 08:10, DaveD <mythtv at guiplot.com> wrote:

> Can someone tell me what causes this:
> DVBRead mpeg/mpegstreamdata.cpp:362 (AssemblePSIP) - Error: offset>181,
> pes length & current cannot be queried
> It shows up in the backend log during recording and results in a few
> seconds of corruption in the recording.  It happens very rarely on most
> channels, but on one channel (of course, my favorite, PBS) it is extremely
> chronic.  This is the only 720p channel I record.  All the rest are 1080i
> or standard def.  Some of the PBS recordings are error-free, but more are
> corrupted periodically, every 20-40 seconds, all the way through.  I
> believe all content on this channel is 720p.
> I never saw this problem in 0.24 (FC13), only after upgrade to Fedora 17
> and 0.25 (mythbackend version: fixes/0.25 [0.25.2-2.fc17
> (v0.25.2-15-g46cab93)]).
> Google turned up a few hits with this error, but it seemed to only be
> related to HDHomeruns, and seemed to be signal.  I'm using an internal
> Dvico Dual Fusion.  My backend is not overloaded and has no trouble
> recording two 1080i shows while playing back recordings with no corruption
> whatsoever.  A single, system-doing-nothing-else recording on the 720p, PBS
> channel is more likely to be corrupted than not.  I was surprised, though,
> as I looked through my PBS recordings, that some of the shows are perfect,
> but shows recorded soon before (or after) were corrupt.  It seems to be
> content-related.
> Any ideas?  Is this a known issue?  Will 0.26 upgrade fix it?
> Dave D.

Check out my recent thread on the same error:


I did track down an Ubuntu forum post about this.  The guy there said it
was down him having EIT enabled for channels that did not have any EIT data.

I have been through my channel listings and sorted out a raft of them that
had "NO DATA" next to them, guessing old Freeview channels that no longer

I do still get the odd entry for this error, but used to get hundreds,
can't track down which channel is still causing the problem

You said you get it for the odd channel?  How do you know?  Does it only
appear when you tune to that channel?

I am getting another error, which may indicate another channel that is
getting bad EIT data, so could be my culprit:

mythlogserver: mythbackend[4063]: E EIT mythdb.cpp:183 (DBError) DB Error
(change_program):#012Query was:#012UPDATE program SET starttime = ?,
endtime   = ? WHERE chanid    = ? AND       starttime = ?#012Bindings
were:#012:CHANID=1225, :NEWEND=2012-11-08T04:00:00Z,
error was [2/1062]:#012QMYSQL3: Unable to execute statement#012Database
error was:#012Duplicate entry '1225-2012-11-08 00:00:00-0' for key 'PRIMARY'

Hopefully this is bad EIT, rather than bad database!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20121104/32c47f48/attachment.html>

More information about the mythtv-users mailing list