[mythtv-users] Finding a suitable device for a Harmony remote

Martin Moores moores.martin at gmail.com
Sat Mar 17 08:22:02 UTC 2012

On 5 March 2012 14:46, Tim Draper <veehexx at gmail.com> wrote:

>  >
> if you haven't found it,
> http://forums.logitech.com/t5/Harmony-Remotes-Programming/Expanded-control-for-Windows-Media-Center-now-available-in-our/td-p/374844
> or in short...
> Device type: Computer -> Media Center PC
> Manufacturer: Microsoft
> Model: Windows Media Center SE
Hey all,

Just wanted to follow up on this, to see how well anyone else has this

I found all this very useful and did manage to get my Harmony 300 working
(mostly) using the Windows Media Centre SE device from Harmony, along with
the MS Windows device selection in LIRC.  This needs some tidying up, but
most of the buttons work, which is great.  I have had many failed attempts
in the past, so thanks for the info here!

One thing I am struggling with though, is setting up some extra buttons,
for example, I have allocated some buttons to "Alt+2" and other number
keys, which I want to link to aspect ratio change etc.

When running irw, I get output for all keys, apart from the ones I have
changed, it doesn't just seem to be the ones that are 2 key presses
either.  I have mapped the "Delete" command to a button, but get nothing
for that either.  So it appears to just be "non-standard keys".  I do see
the receiver flashing when I press these keys.  The exception to this is
"RecTV", "Videos", "Music" and "Pictures", which get picked up OK.

I went on to try irrecord, but could not get that working with my receiver,
it errors out at first with:

"irrecord: could not get file information for /dev/lirc"

So I instead ran with the "-d" to specify a device,
"/devices/virtual/rc/rc0/input7" failed and I got the same error message.
But "/var/run/lirc/lircd" did allow irrecord to continue until it was
waiting for key presses, but pressing any remote keys and irrecord bails
out with:

irrecord: error reading from /var/run/lirc/lircd
irrecord: No such file or directory
irrecord: no data for 10 secs, aborting
irrecord: gap not found, can't continue

If anyone has tried the same Harmony device setup and can shed any light,
would be much appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20120317/61b3e185/attachment.html 

More information about the mythtv-users mailing list