[mythtv-users] mythcenter-wide gui refresh rate

David Farmer remrafevad at gmail.com
Wed Jul 18 13:01:28 UTC 2012

On Tue, Jul 17, 2012 at 6:05 PM, David Farmer <remrafevad at gmail.com> wrote:

> On Mon, Jul 16, 2012 at 7:04 PM, David Farmer <remrafevad at gmail.com>wrote:
>> On Sun, Jul 15, 2012 at 6:55 PM, David Farmer <remrafevad at gmail.com>wrote:
>>> Recently I updated MythTV
>>> [2012-07-04 16:51] upgraded mythtv (1:0.25-3 -> 1:0.25.1-1)
>>> and
>>> [2012-07-09 17:25] upgraded mythtv (1:0.25.1-1 -> 1:0.25.1-2)
>>> and have noticed that the MythCenter-wide theme doesn't like using my
>>> default refresh rate of 1080p at 60Hz. When using the earlier version
>>> 0.25-3 I didn't have this issue. I have the “Separate video modes for
>>> GUI and TV playback” checked.
>>> Frontend log gives
>>> 2012-07-15 18:10:21.973686 N  Desktop video mode: 1920x1080 59.939 Hz
>>> 2012-07-15 18:10:21.978472 I  max_width: 1920 max_height: 1080
>>> 2012-07-15 18:10:21.978500 I  Trying 1920x1080 0.000 Hz
>>> 2012-07-15 18:10:22.199381 I  SwitchToGUI: Switched to 1920x1080 0.000 Hz
>>> which results in 1080i at 50Hz on my screen. If I begin playing a
>>> recording, Myth then gives me 1080p at 50Hz, and stopping the recording
>>> keeps it at that setting.
>>> Can I set the theme to accept 60Hz again?
>> But what is the last video you tried to play ?
>> If you set the refresh rate to "Auto" it will set your screen refresh
>> rate to the framerate of the last video played
>> I'm in Australia and all my recordings are at 50Hz. I do have it set to
>> auto, and after playing any recording Myth automatically sets it to
>> 1080p at 50Hz, and it stays there from then onwards.
>>  But the GUI doesn't seem to recognise my 60Hz setting upon startup since
>> the update described. I liked this setting for a really smooth GUI
>> experience (not just in Myth but all programmes). At 1080i I seem to get
>> those awful deinterlace-style lines through the Myth GUI, which only goes
>> away after playing the first recording. Once I close Myth, my display
>> reverts to 60Hz for all other programmes.
> I don't see how you could see "awful deinterlace-style lines through the
> Myth GUI" provided the GUI is never interlaced to start with...
> The GUI has barely any animated content, don't see how 50Hz would be any
> different the 60Hz... I'm afraid the issue isn't on your computer
> I don't know what else to say, except that I am seeing what I am seeing.
> I only have 3 modelines in my xorg, 1080p at 60, 1080p at 50, and 1080p at 24.These will actually refresh correctly for 59.94 and 23.97 rates too. If the
> display receives any signal that does not fit these refresh rates, it
> defaults to 1080i at 50Hz, which is what I am seeing until I play the first
> recording or close Myth.
> I understand that no part of the GUI is interlaced, but from that update
> onwards as Mythfrontend is initially opened my display does not seem to
> interpret the signal as any recognised refresh rate and so changes to
> 1080i. This results in jagged lines on every application displayed my pc,
> including the desktop if I minimise Myth. But I know it is not being sent
> from the pc that way, because a screen capture taken at this time and
> viewed once Myth is closed appears normal (as does everything once Myth is
> closed or a recording is played).

Then either your mode lines are wrong (for those, you usually don't have to
set any as they would already be defined in the EDID)
Or you have seLected the wrong refresh rate in the settings.

If I were you, I would delete all your mode lines settings and whatever
custom stuff you've added to xorg.conf, reboot and let X do it's job

I haven't got any custom modelines, only select EDID modes,

--- Modes in ModePool for Panasonic-TV (DFP-0) ---
 "nvidia-auto-select" : 1920 x 1080 @  50.0 Hz Interlace  (from: EDID)
 "1920x1080"          : 1920 x 1080 @  50.0 Hz Interlace  (from: EDID)
 "1920x1080_50i"      : 1920 x 1080 @  50.0 Hz Interlace  (from: EDID)
 "1920x1080_60"       : 1920 x 1080 @ 59.94/60 Hz (CEA-861B Format 16)
(from: EDID)
 "1920x1080_50"       : 1920 x 1080 @ 50 Hz (CEA-861B Format 31) (from:
 "1920x1080_24"       : 1920 x 1080 @ 23.97/24 Hz (CEA-861B Format 32)
(from: EDID)

I've only got the bottom 3 in my xorg,
Modes      "1920x1080_60" "1920x1080_50" "1920x1080_24"

I've also tried rebooting with the "Modes" line commented out, and
also without xorg completely. Both of these last two options choose an
incorrect refresh rate, hence why I included the "Modes" option.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20120718/a9e77f8e/attachment.html>

More information about the mythtv-users mailing list