[mythtv-users] Can't watch TV Permission Denied opening recording file despite chmod a+rwx

John Brown jb2904 at johnbrown.com.au
Wed Jul 11 00:39:39 UTC 2012

Sure, but I am not sure where to put it. I've never contributed to a wiki before. Where should it should go?


-----Original Message-----
From: mythtv-users-bounces at mythtv.org [mailto:mythtv-users-bounces at mythtv.org] On Behalf Of R. G. Newbury
Sent: Monday, 2 July 2012 12:16 AM
To: Discussion about MythTV
Subject: Re: [mythtv-users] Can't watch TV Permission Denied opening recording file despite chmod a+rwx

On 07/01/2012 06:35 AM, John Brown wrote:
> Thanks. Problem solved. Mythtv is evidentally is sensitive to the permission of the mount point when the drive is unmounted rather than the permissions of the mounted folder. Every other program used to access the same drive uses the permissions of the mounted folder. If this is not a mythtv bug then I'd consider it to be an extremely undesireable feature!
> To solve the problem, I unmounted the drive (I had to find then kill a few process that were accessing the drive to do this), and noticed the mount point (/media/data) had a user/group of root/root. Since various data and programs use the mounted drive I didn't want to change it to group 'mythtv'. Instead I changed the group of the mount point to 'users':
> chgrp users /media/data
> Then added the mythtv user to the 'users' group
> usermod -a -G mythtv
> I then rebooted as a cheats way of restarting everything and it worked!
> Thanks.

Please consider taking the time to write something in the wiki. There is a page in the Knowledge Base section called TroubleShooting. It needs a new page entry!

Definitely an out of left field sort of error that could catch lots of peope. I've never been affected but only because my media folder has always been the root folder of the drive!


mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list