[mythtv-users] Vaapi use on Sandy Bridge

William Otten williammotten at gmail.com
Fri Jan 27 21:00:02 UTC 2012

On 1/27/2012 5:52 AM, William Otten wrote:
> On 1/26/2012 9:24 PM, Keith Pyle wrote:
>> On 01/26/12 15:46, William Otten wrote:
>>> I'm just getting started in understanding the VAAPI use in Mythtv 
>>> and have
>>> a couple questions concerning it's use. I have read through 
>>> countless posts
>>> and basically understand that VAAPI isn't complete but should be usable
>>> without deinterlacing. I'm currently using a core i5 2405S and an Intel
>>> DH67CFB3 motherboard itx and Ubuntu 11.10 64 bit via Mythbuntu with 
>>> fixes.
>>> I setup a playback profile for VAAPI using VAAPI Acceleration for the
>>> decoder, Openglvaapi for the render and opengl2 for the osd render 
>>> and none
>>> for deinterlacing. When I try to play a tv recording either 720 or 
>>> 1080p, I
>>> hear audio for a second then I get a blank screen then Mythtv 
>>> restarts. I
>>> have attached the frontend log but I don't see any error when the 
>>> problem
>>> happens. Now a bit of history. I followed this post:
>>> http://www.gossamer-threads.com/lists/mythtv/users/501091
>>> Which follows an XBMC post to get an Ubuntu system working with 
>>> VAAPI. The
>>> user says he has a working mythtv .25 with VAAPI (The user has been 
>>> very
>>> helpful). I followed the steps which were pretty simple:
>>> Install
>>> sudo apt-get install libbluray1 i965-va-driver vainfo libmad0
>>> gtk2-engines-pixbuf
>>> Mythtv .25
>>> So my questions:
>>> My attempt at get VAAPI working has failed...what is the problem / 
>>> error in
>>> Mythtv?
>>> Does Ubuntu 11.10 come with all the needed software to support VAAPI?
>>> Is there a way other than the VAAPI selection in Mythtv to know if 
>>> VAAPI is
>>> being used?
>>> Any advice would be appreciated.
>> William,
>> I have not experimented with VAAPI as yet.  However, I do have an i5
>> 2405S running Myth 0.24 quite successfully.  My experience is described
>> in this thread:
>> http://www.gossamer-threads.com/lists/mythtv/users/501137
>> I had an initial problem with mythfrontend crashing whenever I attempted
>> to use OpenGL.  The crash was as you experienced.  We identified the
>> cause as a null pointer reference in the mesa 3D driver, reported the
>> problem to freedesktop.org, and patched mesa with their proposed fix.
>> Since that time, we have had no crashes and video quality is excellent
>> using OpenGL.  The fix to this bug was committed to the mesa repository
>> last week and can be seen at:
>> http://cgit.freedesktop.org/mesa/mesa/commit/?h=7.11&id=9b3ac17991b3b421591111f863f0583ef2f06a01 
>> <http://cgit.freedesktop.org/mesa/mesa/commit/?h=7.11&id=9b3ac17991b3b421591111f863f0583ef2f06a01> 
>> The patch is quite simple and involves one function in
>> mesa/drivers/dri/intel/intel_screen.c.  Another person on this list
>> reported that the patch solved an identical crash for him.  Before
>> diving into much debugging, I suggest you apply this patch to the mesa
>> 7.11.2 code, recompile it, and give it a test.
>> Keith
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://www.mythtv.org/mailman/listinfo/mythtv-users
> I would love to test the patch but have no idea where to start or how 
> to do it. If you could give some guidance please.
> Thanks
By chance I found a video that didn't crash while using vaapi. It wasn't 
correct though (had a solid light-green screen that would pop up every 2 
seconds for about a millisecond) but I was able to monitor the cpu usage 
which was much lower.
Also is there anyone that can help me impliment the mesa patch so I can 
test? It sounds like from what the other users have expressed that it 
should solve my problem. I have tried the xorg-edgers ppa but I'm not 
sure the patch is in there.

More information about the mythtv-users mailing list