[mythtv-users] Mirobridge will not run after Miro update to 4.0.3

Eric N sheed03 at gmail.com
Mon Jan 2 02:59:01 UTC 2012

On Sun, Jan 1, 2012 at 11:40 AM, Doug Vaughan <r.d.vaughan at rogers.com>wrote:

> Eric,
>     Try running the Miro 4.0.3 application. All you need to do is start
> it and see that it is functioning correctly. With each new release Miro
> does a number of updates the first time it is run, mainly to its data
> base. After that, run Mirobridge from the command line with these
> command line options:
> /where ever you have the script/mirobridge.py -Vt
> If you get a "The environment test passed !" displayed you should be
> good to go, otherwise reply to this post with the results from the test.
> One other option would be to update your MythTV install. Miro 4.0.2 and
> higher is supported by MiroBridge with MythTV v0.23 and higher.
> For MythTV v0.23 MiroBridge will show v0.5.8 as that was the version
> released with MythTV 0.23. The version of MiroBridge changes with every
> release of MythTV. If you have the file:
> /where ever you have the script/mirobridge/mirobridge_interpreter_4_0_2.py
> then you have the code that supports Miro v4.0.2 and higher.
> Good Luck
> Doug
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

Thanks for the tips Doug.  I verified that the latest version of Miro runs
fine.  I recall when I first launched Miro after the upgrade to 4.0.3 that
it asked to upgrade the current Miro database, which I let it do.  I then
saw that downloading videos was fine within the interface.  After running
Miro itself again today and then closing, I tried running mirobridge again
and got the same error message:

eric at mythtvback:~$
/usr/share/doc/mythtv-backend/contrib/imports/mirobridge/mirobridge.py -Vt
2012-01-01 21:52:37,270 - mirobridge - INFO - Using python library
'pyparsing' version 1.5.2
2012-01-01 21:52:37.289 Python Database Connection: Using connection
settings from /home/eric/.mythtv/config.xml
2012-01-01 21:52:37,386 - mirobridge - CRITICAL - Importing Miro functions
has an issue. Miro must be installed and functional, error('NoneType'
object has no attribute 'get')
eric at mythtvback:~$

I was curious to see if simply replacing the mirobridge files with the
latest version of mirobridge available at the mythtv github repo would
solve the problem.  So I made a backup of my current mirobridge directory,
and replaced it with the mirobridge directory from the latest mythtv
source.  Unfortunately it still did not work, and I got the following error:

eric at mythtvback:~$ sudo rm -r
eric at mythtvback:~$ sudo cp -r
eric at mythtvback:~$
/usr/share/doc/mythtv-backend/contrib/imports/mirobridge/mirobridge.py -Vt
2012-01-01 21:56:04,402 - mirobridge - INFO - Using python library
'pyparsing' version 1.5.2
2012-01-01 21:56:04,421 - mirobridge - CRITICAL - MythTV python bindings
could not be imported, error(No module named database)

So it sounds like I can't upgrade the version of mirobridge without first
upgrading MythTV to at least version 0.24?  Or is there another way to
update mirobridge itself and still maintain my current version of mythtv?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20120101/f9def227/attachment.html 

More information about the mythtv-users mailing list