[mythtv-users] MythTV 0.24.1, Ubuntu 11.04 and MHEG on Freeview UK

Paul dazzle at edazzle.net
Sun Sep 25 15:16:20 UTC 2011

>Was this something that happened after a MythTV update or after some
>other change?  If it's a MythTV update then could you could try git
>bisect to pinpoint the problem.  I know it's long winded but it
>ultimately works.

I don't think it is MythTV as such. I have tried 0.24, 0.24.1 and 0.24.1
fixes, as well as the pre-packaged MythTV distributed by Ubuntu and they all
have the same problem.

>If it happened without a MythTV change then perhaps look at Ubuntu
>package updates - try less /var/log/dpkg.log

My dpkg.log only goes back to the 24th September and the problem occurred
around the 10 September.

I don't normally use the 'red button' stuff but I noticed it when I had
finished a re-tune and was checking the channels, then I wanted to test the
iPlayer MHEG patch and realised nothing was coming up, so I am not really
sure when the 'red button' stopped working.

>I can't get my head around why MHEG startup should take 6 minutes.
>There's a problem lurking here.

I have since tested the 'red button' on ITV1 and Channel 4 and they show the
teletext service, but the CPU goes up to 150% usage (using both cores on the
Atom 330) and it is so slow in re-drawing the information that it is
unusable and still no 'red button' service on any BBC channel.

I also found the program RedButton MHEG Engine
(http://redbutton.sourceforge.net/), compiled it and ran it, tuning into BBC
News 24 and that displays fine with no problem - high CPU (which I put down
to non-accelerated video) usage but no delays or anything on the MHEG - but
if I run it in verbose mode I get an endless list of MHEG audio buffer
underruns and the MHEG and video slows down, run the software not in verbose
mode and it is fine.

At this juncture I am stumped and can't think of anything else to try or
think that no one else has had a similar problem.


More information about the mythtv-users mailing list