[mythtv-users] Slightly OT: XC5000 problem

Harry Orenstein holists at optonline.net
Wed Sep 21 01:46:55 UTC 2011

On Tue, 2011-09-20 at 09:18 -0400, Devin Heitmueller wrote:
> On Mon, Sep 19, 2011 at 11:38 PM, Harry Orenstein <holists at optonline.net> wrote:
> > I am having a problem with getting my HVR-950Q to tune.  The problem
> > seems to be solved if I unload the modules au0828, au8522 and xc5000 and
> > then load xc5000 first.  When au0828 loads on boot up it seems to
> > automagically load the two others but xc5000 apparently gets loaded
> > last, which is a problem.  Does anyone have a suggestion as to what I
> > could put in a conf file in /etc/modprobe.d that would force xc5000 to
> > load before au0828 gets a chance to load it.  I seem to remember that
> > there was something like this early on for lirc, but cannot find an
> > example.
> >
> > In case anyone is interested in the specifics of the problem my dmesg
> > output indicates "xc5000: Device not found at addr 0x61 (0xffff)" when
> > xc5000 loads last and "xc5000: Successfully identified at address 0x61"
> > when loaded before au0828.  I am running Fedora 15 kernel
> > 64-bit.  I'm guessing that this is really a regression problem since I
> > seem to remember not having this problem prior to a few kernel upgrades
> > ago (I think the distributed kernel started at 2.6.38).  If anyone is
> > using a card with an xc5000 tuner successfully with Fedora 15 and has
> > another suggestion for a work-around or suggestions about what I might
> > be doing wrong that would be a big help too!
> >
> > Thanks in advance for any helpful suggestions!
> Hi Harry,
> I had a user show this to me on an Ubuntu box a couple of weeks ago.
> I haven't had a chance though to dig into it to track down the issue
> further.  Any quantitative feedback you can provide regarding the
> circumstances under which the problem occurs is welcome.

I'm not sure what 'quantitative feedback' you would want, but I'll try
to provide a bit more detail.

> Does it happen 100% of the time at boot?  Are you sure it is a module
> load order issue?  In the user I talked to, it went away just by
> unplugging/replugging (no need to reload modules), but admittedly
> reloading modules is probably easier to do from a terminal prompt if
> you're not in physical proximity of the hardware.

Without any changes or pulling and replacing the USB stick it was
happening about 95% of the time at boot.  I tried creating an entry
in /etc/modprobe.d for au0828 that had the line "softdep au0828 pre:
xc5000 post: au8522" in it.  If I read the documentation correctly this
should force xc5000 to load before au0828 is loaded and then load
au8522.  At first this seemed to fix the problem at every boot, but I
tried again after I read your response and it failed that time.  I also
tried unloading the au0828, au8522 and xc5000 modules (in that order)
and then reloading xc5000 and au0828 (in that order) which fixes the
problem most of the time but, again, not always.  I've tried plugging
and unplugging the stick and that worked also, but I haven't tried
repeatedly to see if it always works.

The problem seems to be worst when the xc5000 device not found message
appears in the dmesg output.  When the xc5000 successfully identified
message appears the stick seems to work.  But I don't think it is a
perfect indicator.  The error I most often get in mplayer is that the
device cannot be tuned to the channel.

If there are some specific things you think I should check (like debug
output) I would be happy to try them out.  Please let me know, and
thanks for the help!

-- Harry O.

More information about the mythtv-users mailing list