[mythtv-users] PVR-150s failing to record

Anthony Zawacki azmail at thezawackis.com
Sun Sep 11 05:21:36 UTC 2011


Hi all,

I've recently upgraded my backend from CentOS 5 (standard kernel)/ 
MythTV .19 to CentOS 6 (standard kernel)/ MythTV 24.1-fixes 
(v0.24.1-78-g8b9e5ce) after having MythTV running successfully for 
probably close to 5 years.  I have a headless master backend and two 
frontends.

Getting use to the new version has taken some time, but I'm running into 
a few different issues, and I'm not sure where or how to start debugging 
them.  I have 2 PVR-150s connected to two dish network receivers via 
S-Video.  Everything works fairly well for two to three days after which 
the both of the cards stop recording.  When this happens, the only way 
to fix it is to reboot the machine.  Stopping and restarting mythbackend 
does not fix the problem.

When I try to tune to live tv to see what is happening, the "tuning" 
screen shows no "signal lock" and it stays black before something gives 
up and sends the front end back to the menu screen.  I've captured logs 
trying to watch live tv with the backend set to "most" after the errors 
start happening, but in reviewing the logs, I don't see a lot of 
specific things (at least to me.)  These are the lines around the area I 
think the error is occurring:

2011-09-10 09:32:57.293 TVRec(1) Error: SignalMonitor failed
2011-09-10 09:32:57.465 TVRec(1): ClearFlags(NeedToStartRecorder,) -> 
FrontendReady,RunMainLoop,CancelNextRecordin
g,WaitingForSignal,SignalMonitorRunning,DummyRecorderRunning,RingBufferReady,
2011-09-10 09:32:57.406 SignalMonitor: channel change failed
2011-09-10 09:32:57.505 MythEvent: SIGNAL 1
2011-09-10 09:32:57.484 MythEvent: UPDATE_RECORDING_STATUS 1 1350 
2011-09-10T08:10:00 -9 2011-09-10T09:50:00
2011-09-10 09:32:57.567 TVRec(1): TeardownSignalMonitor() -- begin
2011-09-10 09:32:57.606 SM(/dev/video0)::Stop: begin
2011-09-10 09:32:57.595 SignalMonitor: channel change failed
2011-09-10 09:32:57.382 MythSocket(19e9b00:50): write -> 50 154 
BACKEND_MESSAGE[]:[]SIGNAL 1[]:[]Channel Tuned
[]:[]tuned 2 3 0 3 ...
2011-09-10 09:32:57.646 MythEvent: SIGNAL 1
2011-09-10 09:32:57.663 MythSocket(19e9bb0:45): write -> 45 154 
BACKEND_MESSAGE[]:[]SIGNAL 1[]:[]Channel Tuned
[]:[]tuned 2 3 0 3 ...
2011-09-10 09:32:57.721 MythSocket(19e9b00:50): write -> 50 154 
BACKEND_MESSAGE[]:[]SIGNAL 1[]:[]Channel Tuned
[]:[]tuned 2 3 0 3 ...
2011-09-10 09:32:57.743 MythSocket(19e9bb0:45): write -> 45 154 
BACKEND_MESSAGE[]:[]SIGNAL 1[]:[]Channel Tuned
[]:[]tuned 2 3 0 3 ...
2011-09-10 09:32:57.753 MythEvent: SIGNAL 1
2011-09-10 09:32:57.904 SM(/dev/video0)::Stop: end
2011-09-10 09:32:57.922 TVRec(1): TeardownSignalMonitor() -- end


Any suggestions on where to look?

Thanks,
Anthony
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mythbackend-cant_tune-most.log.bz2
Type: application/x-bzip
Size: 9073 bytes
Desc: not available
Url : http://www.mythtv.org/pipermail/mythtv-users/attachments/20110911/1cb80445/attachment.bin 


More information about the mythtv-users mailing list