[mythtv-users] Best front-end machine?

Ian Clark mrrooster at gmail.com
Tue Sep 6 12:51:11 UTC 2011

On 6 September 2011 13:20, Frans Grotepass <grotepass at gmail.com> wrote:
> On Tue, 6 Sep 2011 10:48:54 +0100
> Ian Clark <mrrooster at gmail.com> wrote:
>> I'm compiling myth from source, currently it is using the VA-API stuff
>> for playback, but it sounds like I might need opengl support compiled
> If you say: "build from source" do you mean a full build from source or
> a slackware/gentoo style build from source?
Full build from source. :)

Full procedure:

Install minimal deb 6 in a VM
Update initrd to boot from NFS, regen initramfs
Copy whole lot to NFS server and setup for netbooting
Netboot it.
Build/install git
download myth from git

install missing deps
install missing deps
install missing deps
...[until it builds]
start mythfrontend.

>> in too.is that the 'radeon' driver in /etc/X11/xorg.conf?
>> I shall have a look at this later on... ta. :)
> Yup, radeon is correct. I don't have anything set in xorg.conf. Using
> the latest x11 that does auto detection.

I'll have another play later. I don't get autodetection working,
unless I netboot it in a VM, I suspect this is due to fglrx (or
whatever it's called) being loaded, I'll nix that and try again later

I did try with radeonhd manually specified, but this crashed the x
server when using the VA-API playback profile. (again, possibly due to
the ATI kernel module being loaded at the time...)

Thanks for the info, it's interesting to know, esp as I have an old
ATI card just lying around...


More information about the mythtv-users mailing list