[mythtv-users] kernel 2.6.39 and lirc 9.0 problems

Dan Littlejohn dan.littlejohn at gmail.com
Sat Sep 3 23:10:01 UTC 2011

On Sat, Sep 3, 2011 at 1:59 PM, Manuel McLure <manuel at mclure.org> wrote:

> On Fri, Sep 2, 2011 at 12:17 PM, leo weppelman
> <leoweppelman at googlemail.com> wrote:
> >
> > I used this thread:
> http://forum.xbmc.org/archive/index.php/t-104541.html
> I've had no luck with Gentoo 2.6.39 and lirc 0.9.0 (I'm using the imon
> reciever in an Antec Veris case.) I finally managed to get the events
> to be generated (KEY_UP, KEY_DOWN, etc.) as listed by "ir-keytable -t"
> (and they worked at a console prompt - for example pressing the "UP"
> button on the remote would fo to the previous item in the shell
> history) but MythTV would just sit there at the main menu - not even a
> physical keyboard hooked up to the machine would work in MythTV. I
> gave up and went back to 2.6.35 with 0.8.7 which works great.
> --
> Manuel A. McLure WW1FA <manuel at mclure.org> <http://www.mclure.org>
> ...for in Ulthar, according to an ancient and significant law,
> no man may kill a cat.                       -- H.P. Lovecraft
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

Leo's link was very helpful.  This is what I have learned.  I had an old
version of v4l-utils and ir-keytable -t did not work.  I upgraded it.

I was not able to get ir-keytable -t to work with 2.6.39 at all for some
reason.  I was able to get dmesg entries with

    modprobe ir-kbd-i2c debug=1

but no output from ir-keytable -t.  The guide Leo linked to was very helpful
to clue me in that if ir-keytable -t did not work, then there was a problem
with the driver.  I finally compiled a new 3.0.3 kernel, modprobe
ir-kbd-i2c, and ir-keytable -t just worked with no configuration changes.  I
compiled lirc 9.0 again with LIRC_CONFIG='devinput', copied
lircd.conf.devinput to /etc/lirc/lircd.conf, and started

    lircd -n -H devinput -d /dev/input/event4

then irw showed keypress events.  I thought I was in the good to go at that
point, but not quite.  My limited understanding is that mythtv still needs
lirc in order to see remote events, but I could not seem to sort that out.
Mythtv did not respond to the remote events irw did.  WAF became low so I
reverted back to 2.6.35 and lirc 8.7 for now.

If I do get some time soon to revisit this and figure out why mythtv does
not see the lirc events, I will try to copy what Douglas Clowes posted in
another thread to reverse pass events to my serial IR blaster.

    lircd --driver=devinput --device=/dev/input/event4
    ir-keytable -p LIRC
    lircd --output=/var/run/lirc/lircd_send

I believe I eventually will need to figure this out, but as the newer kernel
worked a lot better for me maybe this still needs a bit more time to bake
and for more commits to be made to the kernel and other software.

Hopefully, this info helps someone else.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110903/34a75dfd/attachment.html 

More information about the mythtv-users mailing list