[mythtv-users] mythfilldatabase problems

Dan Wilson dwilson at solidstatesoftware.com
Fri Sep 2 19:09:13 UTC 2011

On 08/31/2011 12:47 PM, Michael T. Dean wrote:
> On 08/31/2011 12:19 PM, Dan Wilson wrote:
>> With the Dish Network lineup configured on Schedules Direct, I get
>> mythfilldatabase failures. --dd-grab-all never works (timeouts).
>> Individual daily grabs sometimes work, but fail more often than not.
>> Confusingly, some daily grabs seem to have worked, but a subsequent
>> mythfilldatabase run claims that no data is present and repeats the grab
>> again (which still doesn't seem to have worked).
> ...
>> Connecting to
>> webservices.schedulesdirect.tmsdatadirect.com||:80...
>> connected.
>> HTTP request sent, awaiting response... 200 OK
>> Length: unspecified [text/xml]
>> Saving to: “STDOUT”
>> [<=>   ] 38,720 7.85K/s 2011-08-31 10:43:47.010 DataDirect: Your
>> subscription expires on Wed Sep 28 11:23 PM
>> [<=>   ] 237,994 --.-K/s in 19m 47s
>> 2011-08-31 11:03:29 (200 B/s) - Read error at byte 237994 (Connection
>> timed out).Retrying.
> http://www.gossamer-threads.com/lists/mythtv/users/486663#486663
> perhaps?  (Only if you're using ext4 for the file system that holds the
> mysql database data--likely your root file system.)

Indeed, that thread had pertinent information, although the problem 
didn't seem to be the ext4 file system.

I believe that the timeout occurred because the database accesses were 
simply taking too long. mythfilldatabase would appear to hang because it 
was waiting for data from data direct, but data direct had already timed 
out on the download. So mythfilldatabase waited until it's own timeout 

I ordered an SSD drive and it arrived today. After copying 
/var/lib/mysql onto the new drive, then mounting it on top of 
/var/lib/mysql, I brought mysqld and mythbackend back up.

Individual daily updates dropped from 18+ minutes on the regular hard 
drive (when they didn't time out and fail) to 2 minutes on the SSD, and 
I haven't seen a single failure so far.

However, I still see the problem where mythfilldatabase runs, says it 
updates the schedule for a day, but then an immediate re-run of 
mythfilldatabase says there isn't any data present for that day and it 
runs that day's update again (which also doesn't seem to work). It 
doesn't fail on every day, but it seems to fail consistently on the same 
days. Weird.

My next test was: mythfilldatabase --dd-grab-all

It took 25 minutes, and didn't time out! This is a first since switching 
to Dish.

Information Center/System Status says I have 14 days worth of data. The 
Scheduled Programs page shows at least one program being recorded on 
each day.

I think I'm in business! Switching to an SSD for the mysql database was 
worth every penny of the $74 I paid (including overnight shipping from 

Thanks for the help,


More information about the mythtv-users mailing list