[mythtv-users] kernel 2.6.39 and lirc 9.0 problems

Dan Littlejohn dan.littlejohn at gmail.com
Thu Sep 1 15:34:10 UTC 2011

I am running gentoo and recently upgraded my myth box.  Everything seemed to
go well, but I am having problems getting lirc to work again.  This is a
frontend with a pvr350 that I use for the remote input and an ir blaster to
change channels on my satellite box so I need to get both a hauppauge grey
remote and an ir blaster working at the same time

Before the upgrade, I was running lirc8.7 and kernel 2.6.35, and at boot I
would load lirc_i2c and lirc_serial.  My init.d lircd file looked like this

start-stop-daemon --start --pidfile /var/run/lirc/lircd1.pid --quiet --exec
/usr/sbin/lircd -- --driver=default --device=/dev/lirc1
--output=/var/run/lirc/lircd1 --pidfile=/var/run/lirc/lircd1.pid

start-stop-daemon --start --pidfile /var/run/lirc/lircd.pid --quiet --exec
/usr/sbin/lircd -- --driver=default --device=/dev/lirc0
--output=/var/run/lirc/lircd --pidfile=/var/run/lirc/lircd.pid

Now I am using lirc 9.0 and kernel 2.6.39 and understand a lot of stuff has
been moved into the kernel, but I am a bit stumped as to how to get this
working again.  Here is some of the log that shows dmesg and that the keymap
seems to look ok for rc5

one linux # dmesg | grep ivtv

ivtv: Start initialization, version 1.4.2

ivtv0: Initializing card 0

ivtv0: Autodetected Hauppauge card (cx23415 based)

ivtv 0000:05:02.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18

ivtv0: Unreasonably low latency timer, setting to 64 (was 32)

ivtv0: Autodetected Hauppauge WinTV PVR-350

saa7115 0-0021: saa7115 found (1f7115d0e100000) @ 0x42 (ivtv i2c driver #0)

saa7127 0-0044: saa7127 found @ 0x88 (ivtv i2c driver #0)

msp3400 0-0040: MSP4448G-A2 found @ 0x80 (ivtv i2c driver #0)

ivtv0: Registered device video0 for encoder MPG (4096 kB)

ivtv0: Registered device video32 for encoder YUV (2048 kB)

ivtv0: Registered device vbi0 for encoder VBI (1024 kB)

ivtv0: Registered device video24 for encoder PCM (320 kB)

ivtv0: Registered device radio0 for encoder radio

ivtv0: Registered device video16 for decoder MPG (1024 kB)

ivtv0: Registered device vbi8 for decoder VBI (64 kB)

ivtv0: Registered device vbi16 for decoder VOUT

ivtv0: Registered device video48 for decoder YUV (1024 kB)

ivtv0: Initialized card: Hauppauge WinTV PVR-350

ivtv: End initialization

ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)

ivtv0: Loaded v4l-cx2341x-dec.fw firmware (262144 bytes)

ivtv0: Encoder revision: 0x02060039

ivtv0: Decoder revision: 0x02020023

ivtv0: Loaded v4l-cx2341x-init.mpg firmware (155648 bytes)

Modules linked in: snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device

snd_pcm_oss snd_mixer_oss nvidia(P) tuner_simple tuner_types tda9887 tda8290

tuner msp3400 saa7127 snd_hda_codec_hdmi saa7115 ivtv snd_hda_codec_realtek

cx2341x i2c_algo_bit v4l2_common videodev snd_hda_intel tveeprom

i2c_core 8250_pnp snd_hwdep snd_pcm 8250 snd_timer serial_core

ir-kbd-i2c: i2c IR (Hauppauge WinTV PVR-350 detected at i2c-0/0-0018/ir0

i2c driver #0]

one linux # dmesg | grep lirc

lirc_dev: IR Remote Control driver registered, major 253

rc rc0: lirc_dev: driver ir-lirc-codec (rc-loopback) registered at minor = 0

one linux # ir-keytable

Found /sys/class/rc/rc0/ (/dev/input/event2) with:

Driver rc-loopback, table rc-empty

Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other

Enabled protocols: NEC RC-5 RC-6 JVC SONY LIRC other

Found /sys/class/rc/rc1/ (/dev/input/event5) with:

Driver ir-kbd-i2c, table rc-hauppauge

Supported protocols: RC-5       Enabled protocols: RC-5

Currently, I have LIRC_DEVICES='userspace' (have also tried devinput,
default, serial and combos of those).   I enable all the lirc modules and
the ir staging modules in the kernel.

I have tried devinput (lircd –n –H devinput –d /dev/input5) and ir-kbd-i2c
(modprobe ir-kdb-i2c hauppauge=1 with lircd -n -d /dev/lirc0) and neither
seems to work when using iwr, but I do see dmesg key presses when using
modprobe ir-kbd-i2c debug=1, but not in irw.   I am not sure which approach
I should be focusing on to get both the pvr350 remote and the ir blaster to
both work.  I have read everything I can in the list and what I can find,
but it is a bit confusing.  Right now, neither work.  Would appreciate any
advice to get this working.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110901/7b7b1287/attachment.html 

More information about the mythtv-users mailing list