[mythtv-users] Shutdown command failing

aaron memoryguy at gmail.com
Thu Sep 1 10:19:31 UTC 2011

On Thu, Sep 1, 2011 at 02:41, Simon Hobson <linux at thehobsons.co.uk> wrote:
> As a debugging tool, have you tried issuing a shutdown prompt from
> the command line when logged in as the Myth user ? That will at least
> avoid any problems with Myth hiding responses.

Hi Simon, thank you for your feedback. I definitely should have
included that information: yes, everything works correctly when I
enter the commands at the command line. In fact, if I copy the
nvram-wakeup command from the log and execute it, and then copy the
lilo/reboot command from the log and execute it, the machine sets the
wakeup time and then reboots/halts.

I think I have solved the problem, but then I was wondering why it
seemed to be setting the wrong wakeup time. Later, I realized that the
command to set the wakeup time must have been failing the same way,
but it just so happened that a return code of 1 from nvram-wakeup
actually has meaning ("setting the time was successful but a reboot is
required"), so I didn't realize it wasn't working.

Thank you, everyone, for your input on this problem.


More information about the mythtv-users mailing list