[mythtv-users] Much confusion about lirc and mythtv

Mark Boyum mark at boyum.us
Thu Oct 27 21:18:47 UTC 2011

On Thu, Oct 27, 2011 at 4:15 PM, Richard Shaw <hobbes1069 at gmail.com> wrote:
> On Thu, Oct 27, 2011 at 4:08 PM, Gary <gwgrover at windstream.net> wrote:
>> In trying to find valid information about installing and configuring LIRC,
>> The thing that troubling me is that many of the how-to's, wiki's and
>> articles I have seen contain NO DATE.
>> My mythbackend version:  [v0.24.1.
>> For kernel version, the command  "uname -a" produces:
>>      Linux debian 2.6.32-5-amd64 #1 SMP Fri Sep 9 20:23:16 UTC 2011 x86_64
>> GNU/Linux
>> Is there a stable release of Lirc that will work with my OS and mythtv?
>> Where is it documented which release of the linux kernel includes the lirc
>> kernel modules.
> Well it would be helpful to know what kind of remote you're trying to
> configure. Also, if you haven't already, read the MythTV documentation
> for LIRC.
> http://www.mythtv.org/docs/mythtv-HOWTO-8.html
> Richard

Also, have you checked out the LIRC website?
>From the FAQ (http://www.lirc.org/faq.html):
lirc-0.8.7 has been tested with kernel versions up to 2.6.35. Older
versions should also work. 2.4.x kernels are not supported anymore,
but chances are good that it's still working. The last release
officially supporting 2.4.x was 0.8.2. Please don't report problems
with compilation on 2.4.x kernels. 2.2.x kernels are not supported
>From 2.6.36 on all LIRC kernel drivers are already included in the
kernel. There has been a slight interface change in the LIRC ioctls
that will affect 64-bit kernels. For recent kernels please only use
0.9.0 which is compatilbe with the in-kernel drivers.

More information about the mythtv-users mailing list