[mythtv-users] database connection just stopped working

backuppc at sundquist.imapmail.org backuppc at sundquist.imapmail.org
Tue Oct 18 18:25:22 UTC 2011

On Sun, 16 Oct 2011 23:16:23 -0400, backuppc at sundquist.imapmail.org
> Hi all.  Used to lurk (and sometimes post) here lots back when first
> getting set up, but haven't been back for a while because it "just plain
> worked" (TM) and "if it ain't broke, don't fix it".
> After a couple of years, my pcHDTV 5500 died.  Actually, whole system
> froze up, couldn't figure out anything so did a reinstall and it would
> freeze up again when scanning for channels with that card.  Took it out
> and just went with my HDHR and everything worked great.
> Decided to do the mythbuntu 10.04 LTS since this was before 11.11 came
> out anyway, and wanted the long term support.  Installation went really
> really well (once I took out the pcHDTV).  Was all too easy.
> But Thursday night I installed boxee and huludesktop, and something must
> have happened, which I just noticed tonight (was busy with "real life"
> over the weekend).


> 2011-10-14 16:27:04.336 Running mythfilldatabase
> 2011-10-14 16:27:04.479 Using runtime prefix = /usr
> 2011-10-14 16:27:04.480 Using configuration directory = /home/mythtv/.mythtv
> 2011-10-14 16:27:04.480 Unable to read configuration file mysql.txt
> 2011-10-14 16:27:04.481 Empty LocalHostName.
> 2011-10-14 16:27:04.481 Using localhost value of mythtv
> 2011-10-14 16:27:04.522 New DB connection, total: 1
> 2011-10-14 16:27:04.544 Unable to connect to database!
> 2011-10-14 16:27:04.545 Driver error was [1/1045]:
> QMYSQL: Unable to connect
> Database error was:
> Access denied for user 'mythtv'@'localhost' (using password: YES)
> I've gone through all the database troubleshoots, and it seems things
> work fine.  For example:
> user at mythtv:~$ mysql -u mythtv -p
> Enter password: 
> Welcome to the MySQL monitor.  Commands end with ; or \g.
> Your MySQL connection id is 1035
> Server version: 5.1.41-3ubuntu12.10 (Ubuntu)
> Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
> mysql> 
> Also, it says can't find mysql.txt, but...
> user at mythtv:~$ locate mysql.txt
> /etc/mythtv/mysql.txt
> /home/user/.mythtv/mysql.txt
> /home/mythtv/.mythtv/mysql.txt
> /usr/share/mythtv/mysql.txt.dist
> user at mythtv:~$ 
> and all those files (except the .dist one) are links to the one in /etc:
> user at mythtv:~$ for i in `locate mysql.txt`; do file $i; done
> /etc/mythtv/mysql.txt: ASCII English text
> /home/user/.mythtv/mysql.txt: symbolic link to `/etc/mythtv/mysql.txt'
> /home/mythtv/.mythtv/mysql.txt: symbolic link to `/etc/mythtv/mysql.txt'
> /usr/share/mythtv/mysql.txt.dist: ASCII text
> user at mythtv:~$

But the solution was super simple.  I had inadvertently changed the
ownership of this file (/etc/mythtv/mysql.txt) to be "user", whereas it
was supposed to be "mythtv".

Once I changed the ownership back, things worked perfectly.  In fact, it
started recording a show right away that was in progress and was
scheduled for recording.

Jon S.

More information about the mythtv-users mailing list