[mythtv-users] Small error when exiting mythfrontend + channel change crashing

Jerry mythtv at hambone.e4ward.com
Sun Nov 6 16:33:32 UTC 2011

I see this in the log:

     Error in my_thread_global_end(): 1 threads didn't exit

Is this harmless?  Things seem to work afterward but then again...

I'm having trouble with channel changing in LiveTV.  Sometimes, the screen
locks up entirely.  I'll repost the logs I did before when I produced a
crash in mythbackend.

Here is my mythbackend.log -- http://pastebin.com/ne674hcU
and mythfrontend -v important,general -- http://pastebin.com/FGqmgSFH

I wasn't sure if the version update would fix the channel change crashes
but it appears that they are still with me.

I don't mean to double-post but I wanted to clarify this additional error.
Most of the time, I change channels and my machine gets stuck in a loop
with the screen going black, usually without audio.  I can ESC back to the
main menu eventually.  In the instance documented above, mythbackend
crashed entirely and had to be restarted.  This was a case of frequent
channel changes, like one every five seconds.  I was trying to produce an

This is the last thing entered in the mythbackend.log before mythbackend

     2011-11-06 08:10:19.261 TVRec(1): Changing from WatchingLiveTV to None
     QMutex::lock: mutex lock failure: Invalid argument

I continue to see this next error:

      LoadFromScheduler(): Error, called from backend.

It frequently occurs between channel changes.  That may be innocuous --
others say that it is.
I don't see the error that is occurring to cause the looping shown below:

     2011-11-06 08:09:51.211 Player(0): Waited 100ms for video buffers

I just tried it again, the screen went black, the disk went in a loop, and
I was able to recover to the main menu.  This was only after one channel
change.  Then, after restarting mythbackend, channel changes worked as
expected, with at least ten channel hops.

I was just reading a thread from September.  Is this something that the
developers are not concerned about (LiveTV), or do I have a problem that
can be addressed?

If I'm not giving detailed enough logs, I'll give it another shot.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20111106/601bc03d/attachment.html 

More information about the mythtv-users mailing list