[mythtv-users] UK - my listings are disappearing

John Veness John.Veness.mythtv at pelago.org.uk
Wed Nov 2 15:32:39 UTC 2011

On 02/11/2011 15:08, Mike Perkins wrote:
> I have realised that I am no longer getting listings updates from the Radio
> Times feed (via xmltv). I have tried to fault find the problem but without much
> success.
> If I run tv_grab_uk_rt manually it appears to succeed, but the output file only
> contains partial schedule data. If I then attempt to load this using
> mythfilldatabase /nothing/ changes, probably because the data replicates what is
> already there from when it worked.
> I can't ping xmltv.radiotimes.com, which means I can't even check if the GETs
> are being intercepted by my firewall.
> If I attempt to web browse to xmltv.radiotimes.com I get a web page which notes:
> Old RadioTimes.com
> Please note we are only updating listings on this site until 30th Sept
> Any ideas?
> $ tv_grab_uk_rt --version
> XMLTV module version 0.5.61
> This is tv_grab_uk_rt version 1.342, 2011/06/19 06:50:36
> $

I don't know all the answers, but I know that the normal behaviour if 
you visit http://xmltv.radiotimes.com/ to see the public homepage of the 
site (actually the old home page hence the message), so .ignore that as 
part of your troubleshooting. The site also seems to be blocking pings 
as I can't ping it either, so that's also normal.

To test properly, you need to try visiting 
http://xmltv.radiotimes.com/xmltv/channels.dat and for example 
http://xmltv.radiotimes.com/xmltv/92.dat to see BBC1 data.



John Veness, MythTV user, UK, DVB-T

More information about the mythtv-users mailing list