[mythtv-users] frontend hangs on livetv on resume-from-suspend

Michael T. Dean mtdean at thirdcontact.com
Wed Mar 9 16:41:14 UTC 2011

On 03/09/2011 03:38 AM, tim draper wrote:
> I've been trying to find a fix for this issue over the last week, but 
> to no avail.
> the problem is when I suspend the computer that mythtv is running on 
> (standalone; BE and FE on same machine) and then wake it up, the 
> frontend will hang the entire computer when it enters liveTV.
> I've tried ending the frontend and backend processes prior to entering 
> suspend, and then manually running them once the computer wakes up; 
> but still the same issue.
> i know the entire computer hangs as my ssh session becomes 
> unresponsive and pings also fail.

If that's the case, it's definitely something lower-level-than-MythTV 
causing the problem.  Something like video drivers, network drivers, or 
maybe capture card drivers (assuming a combined frontend/backend 
system), or ...

> I'm at a loss as where to go from here or what to try next. all my kit 
> is linux compatible, and my tv card specifically states it works with 
> mythtv
> my setup:
> Intel G31 based motherboard
> Intel c2d E6550
> 2gb ram
> Nvidia 210 using HDMI (using the 260.xx propriety drivers that come 
> with mythbuntu)
> mythbuntu 10.10 (mythtv 0.24 + 0.24fixes)
> TBS 6981 dual sat card
> thanks for any help

You may have to unload some module/modules before suspend, then re-load 
them after.

Or, you could just shut down the machine when not in use and then boot 
it--rather than suspend/unsuspend.


More information about the mythtv-users mailing list