[mythtv-users] IR Remote, OpenSUSE, and weirdness

Robin Smith 1canuck2 at gmail.com
Fri Jan 14 20:10:43 UTC 2011

> > Am I correct that the lircd.conf file must "good", in that (for example)
> irw shows:
> >  irw
> > 000000002a8115b7 00 KEY_PLAY /tmp/lircd.record.conf
> > 000000002a8115b7 01 KEY_PLAY /tmp/lircd.record.conf
> > 000000002a8115b7 02 KEY_PLAY /tmp/lircd.record.conf
> > 000000002a8115b7 00 KEY_PLAY /tmp/lircd.record.conf
> >
> > when I press the "Play" button on my remote?
> Yes.
> > If so, am I correct that all that *should* be needed to make this work in
> MythTV is this:
> > begin
> >     prog = mythtv
> >     button = KEY_PLAY
> >     config = P
> > end
> > in my lircrc file (and the lircrc file in the correct place)?
> Almost.
> > If so, how come it still doesn't work? Is there another step I am missing
> to make myth aware of the keypress info? As I said before, this previously
> "just worked" once I got good output from irw that matched my lircrc.
> MythTV has a config option for lircd socket location. In earlier lirc
> releases, this was /dev/lircd, but it was moved at some point over to
> /var/run/lirc/lircd. I'd wager that your frontend is still trying to
> listen for lirc events at the old location. The config screen is in the
> frontend prefs somewhere, don't recall exactly where though.

Aha! That's it.
For the record, it is under Setup > General. About 9 screens in, there's
"Remote Control" setting. My LIRC Daemon Socket setting was, in fact, blank.
Don't know why... I set it to /var/run/lirc/lircd and it now works.

I am having issues with multiple keypresses and not all my buttons are
defined, but I can work those out alone. The main thing is, my Myth is now
responding to remote keypresses!

Thanks again for your help.

Jarod: Sorry you wrote a reply and in the interim I upgraded to 11.3 - I'm
just happy the 11.3 upgrade went cleanly I was being a wimp about upgrading
since everything was working (except for my remote and I was sick of using a
big keyboard).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20110114/9481a5e3/attachment.htm>

More information about the mythtv-users mailing list