[mythtv-users] Fedora 14 & Hauppauge (Grey) & lirc devinput with Nova-T

Jarod Wilson jarod at wilsonet.com
Mon Feb 14 01:23:07 UTC 2011

On Feb 12, 2011, at 5:48 PM, Alex Butcher wrote:

> On Sat, 12 Feb 2011, Jarod Wilson wrote:
>> On Feb 12, 2011, at 6:42 AM, Alex Butcher wrote:
>>> On Fri, 11 Feb 2011, Nigel Jewell wrote:
>>>> I've just moved my Myth installation from CentOS 5 i386, to CentOS 5 x86_64
>>>> and eventually settled on Fedora 14 (x86_64).
>>>> In CentOS 5 my Hauppauge remote (A415-HPG) connected to a Nova-T worked fine
>>>> with lirc using devinput in both architectures using the same lircd.conf.
>>>> Now I've moved to Fedora 14 I cannot get it to work.  If I monitor it using
>>>> "mode2" I can see the events arriving, but irw shows no output and creating a
>>>> file using irrecord is proving to be impossible.  Each time that I run it I
>>>> eventually see the message:
>>>> ..............................................................
>>>> irrecord: could not find gap.
>>>> irrecord: gap not found, can't continue
>>>> This normally occurs towards the end of the first recording stage.
>>> I seem to recall I had the same problem moving my lircd.conf from Fedora 8
>>> to Fedora 14.
>>>> Has anyone managed to get this remote working with Fedora 14?
>>> Yup, try:
>>> irrecord -H devinput -d /dev/input/by-path/pci-[...]-event-ir $HOME/lircd.conf
>>> to generate a new lircd.conf in $HOME
>> Running irrecord for a devinput device is a complete waste of time. Just use
>> the lircd.conf.devinput file provided by the lirc project.
> I tried that; lirc complained that the file was outdated and gave a URL for
> a new version, but was actually exactly the same!

Crap. I think the one at the url is dated now. Try the latest one that is in the
lirc git tree. I'll try to get the url-referenced one updated tomorrow.

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list