[mythtv-users] MythTV dependencies and Ron's Ceton patch

Ronald Frazier ron at ronfrazier.net
Wed Aug 10 21:29:01 UTC 2011

My main patch (the non-mythbuntu one) is actually done against
24-fixes as of a month or so ago, and thus is newer than 24.1 (there's
technically no 24.1-fixes, as 24.1 was a snapshot of the fixes branch
as of last May). The mythbuntu patch was for 24.0. If you compare my 2
patches, they are identical except for a few lines in the configure
file (mythbuntu has some options for Video4Linux2 support that doesn't
seem to be in the official myth version). So if you get the official
fixes branch, my main patch should work, although you'll then be
responsible for figuring out how to get myth to start/stop
automatically, etc...all that stuff that mythbuntu handles for you (if
you go this route, you are on your own...I have no idea how to advise
you on tying into mythbuntu's stuff). If you try to do the mythbuntu
0.24.1 release***, I imagine you would follow pretty much my existing
mythbuntu instructions, just making some adjustments to paths and
filenames as appropriate.

*** Re: mythbuntu 0.24.1 - does such a thing even exist? In your
apt-get output, it appears to, but I'm not sure where you are getting
it. My 11.04 install only has 0.24.0. I couldn't find any way to get a
newer version. If you figure out how, you'll be on your own, as I
haven't any clue how it's done (I've never used mythbuntu except to
build this patch and figure out basic instructions, which I only did
because I knew a lot of people used it). If you do manage to do it and
get it working, if you'd like to share the steps you took to get it
done, it might be helpful to others.

Ron Frazier

More information about the mythtv-users mailing list