[mythtv-users] run script as root at startup

mythtv . mythtv at harley-jones.co.uk
Wed Aug 10 19:03:33 UTC 2011


On 10 August 2011 18:02, Johan.van der Kolk
<johan.van.der.kolk1 at telenet.be>wrote:

> On 08/10/2011 04:50 PM, mythtv . wrote:
> >>    The really tricky part these days is that some distros like Ubuntu
> have
> >> tried to dump init in general and are using alternatives like upstart.
> While
> >> init scripts had their problems, they were widely used and well (enough)
> >> understood.
> > I agree! I had no end of trouble with a FE where mythtv would start
> > before the wireless was connected. Ended up budging it with a delay in
> > the mythftontend script before switching to being wired into a
> > wireless bridge so I could shorten the delay as I couldn't control the
> > order of thongs starting up
> >
> Encountered the same problem, specially since "network up" in upstart
> does not mean that the PC got an IP address, or even a working
> connection. My solution was not to start the FE until I had a successful
> ping to the router.
>
> Mine was a bit more crude than that. I had a separate startup script for
mythfrontend with sleep 10 at the start to allow the wireless to come up!
Then I put dd-wrt on a spare wireless router and turned it into a bridge
which meant I could wire to the bridge via ethernet and reduce the startup
delay significantly but still found I needed 3 or 4 seconds.Its a
mythfrontend in the bedroom which is not often used  so the quick and dirty
hack worked well enough. I did think about pinging the FE first but if to be
honest didnt have the time or inclination to sort it out!

I did switch the wireless to using wicd rather than network-manager (I
prefer the wicd UI and it can be made to start at boot time)

Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110810/eb839845/attachment.html 


More information about the mythtv-users mailing list