[mythtv-users] everyday i have to make sure myth worked the day before

Tom Lichti redpepperracing at gmail.com
Fri Apr 22 17:01:21 UTC 2011


On Fri, Apr 22, 2011 at 12:47 PM, Bruce Taber <b.taber at comcast.net> wrote:
> On 04/21/2011 03:11 PM, Bruce Taber wrote:
>> I'm almost there. Unfortunately, I don't have the problem in that link.
>> Rather, this is the failure I am seeing:
>>
>> 2011-04-21 14:42:07.231 MythCoreContext: Connecting to backend server:
>> 192.168.0.200:6543 (try 1 of 1)
>> 2011-04-21 14:42:14.236 MythSocket(7f519800fdf0:59): readStringList:
>> Error, timed out after 7000 ms.
>> 2011-04-21 14:42:14.236 Protocol version check failure.
>>                       The response to MYTH_PROTO_VERSION was empty.
>>                       This happens when the backend is too busy to respond,
>>                       or has deadlocked in due to bugs or hardware failure.
>>
>> I've had to go back and retest one of the versions. I think there's
>> another way to trigger the problem and I need to test that theory.
>>
>> Bruce
>> _______________________________________________
> Here's where I've gotten to and the result of the git bisect.
>
>  git bisect bad
> 3bb4e17f58bd3bf356373aa2a2ba1526cbe496fd is the first bad commit
> commit 3bb4e17f58bd3bf356373aa2a2ba1526cbe496fd
> Author: Gavin Hurlbut <ghurlbut at mythtv.org>
> Date:   Sun Apr 17 20:25:29 2011 -0700
>
>    Merges in AutoExpire changes from mythtv-rec2

I had a suspicion that might be the one. In my second try at git
bisect route, I am currently compiling exactly that version, so if I
get the same result, I'd say we've found the culprit. I will post when
I've finished my bisect-ing.

Tom


More information about the mythtv-users mailing list