[mythtv-users] LIRC and MythBuntu 10.10

Greg Hormann ghormann at alumni.indiana.edu
Sat Apr 16 18:39:45 UTC 2011


On Sat, Apr 16, 2011 at 2:04 PM, Jarod Wilson <jarod at wilsonet.com> wrote:
> If you enabled it building the same way you did lirc_zilog, but didn't
> add CONFIG_LIRC_SERIAL_TRANSMITTER=y, then you probably only built it
> with RX support.
>
> I forgot to mention that if you want to build the lirc staging bits, you
> need to do a 'make stagingconfig' in the root of the media_build source,
> which should have taken care of that automatically, I think. However, I
> don't know why we don't just always build in TX support, I should remove
> that config option...
>

Actually I did both (with =m) to the .config file  That should work
right?  I *did not* run stagingconfig
ghormann at tvServer:~/mythtv_source/hd-pvr-driver/v4l-dvb-backport/media_build/v4l$
grep SERIAL .config
CONFIG_LIRC_SERIAL_TRANSMITTER=m
CONFIG_LIRC_SERIAL=m

I'm running a test right now with options lirc_zilog tx_only=1 as
David suggested.  No problems after 4 shows being required (even
switching between resolutions).  That is the most stable hd-pvr has
ever been as a transmission device.  I also just started playing with
an MCE Remote. Hopefully I can get that stable too.  (Right now, it
seems to be configured as a keyboard by some other module, instead of
via LIRC.  Time for more google searches!)

Thanks again for all the assistance!

Greg.


More information about the mythtv-users mailing list