[mythtv-users] Question re: available SATA ports and linux software RAID

f-myth-users at media.mit.edu f-myth-users at media.mit.edu
Mon Apr 11 05:43:22 UTC 2011

    > Date: Sun, 10 Apr 2011 23:45:43 -0400
    > From: Mark Lord <mythtv at rtr.ca>

    > On 11-04-10 04:57 PM, f-myth-users at media.mit.edu wrote:
    > >
    > > Note that 3 TB Hitachi's are currently on sale at Newegg today for
    > > $130 after applying a $20 discount code.  Anyone have anything to say
    > > about 'em?

    > I have ALWAYS had bad luck with DeathStar drives,
    > both when branded IBM and when branded Hitachi.
    > Way too many premature failures here on both brands.

I went and read the reviews on the various Hitachi 2TB drives at
Newegg a few hours ago and got the same impression.  There were many
more people complaining about this than the Samsung or WD 2TB's, and
the 3TB only has half a dozen reviews with actual experience.  So I
think I'm going to give that particular 3TB a miss for now.

    > > Oddly, I see various people claiming the MV8 will or won't support
    > > anything over 1 TB, without much agreement.

    > Under Linux, there's no limit there.

Excellent.  I was hoping there wasn't going to be some weird screw
case there where the chipset wasn't just passing data through as I'd

    > The onboard BIOS may have trouble with a 3TB boot drive,
    > but once Linux and sata_mv are loaded, there's nothing in
    > the device driver to prevent full use of the capacity.

Ok.  (No plans to use such a thing as a boot drive.)  [I'll bet
the onboard BIOS has never heard of GPT, for one thing, or might
have addressing limits.]

I've also heard reports that some BIOSes or motherboards can't cope
with more than two MV8's on the PCI bus.  (Simply wouldn't notice the
third one.)  Haven't tried that yet; I have enough of them that I
could pile them all into one machine and give it a try at some

    > I do have a bug report currently of hot-plug failing for one user
    > on that chipset (Marvell 6041/6081) with recent kernels. Not sure why yet.

Hm.  I certainly tried it under Ubuntu 10.10 (2.6.35-28-generic, AMD64),
and it worked for me.  I was able to hdparm -Y the drive and it spun
down; scsiadd detached it and reattached it, and simply pulling the
drive (with no mounted FS on it, of course) also appeared to work even
if I didn't do either of those things, though I try not to do that.

Haven't tried it under the most-current Natty (2.6.38-8.42), but now
that you mention it, I'll give it a try when I have a chance.  Do you
recall the kernel version of the bug report or what the failure mode was?
[I imagine a pointer to the bug-tracker entry would be the right thing.]


More information about the mythtv-users mailing list