[mythtv-users] Using HDMI Disables All Audio?

nospam312 nospam312 at gmail.com
Fri Nov 5 18:57:36 UTC 2010

> worked correctly). I was able to get HDMI to work on mythtv by setting Audio
> Output Driver to
>     ALSA:plughw:x,y
> where x and y are the HDMI card and device number displayed by "aplay -l".

My aplay -l displays a list just like yours (different model number)
ALC662 Analog (0,0), ALC662 Digital (0,1) but no device 3.

Just in case I have tried 0,3 and 0,1 neither work for me.

> 2) Try speaker-test with various values for -D

When I try speaker-test is says playback open error -2 no such file directory

>I second Jim's suggestion of disabling the EDID

I read the message as EDID should be enabled - i.e. "The short story
is, don't put 'Option "UseEDID" "False" ' in your
xorg.conf file." - I do not have this option in my xorg.conf.

>If the TV thinks that audio HDMI is enabled, it will disable the analog audio inputs.

Yes the TV has disabled analog audio input as when I have it set to
ALSA:default I still get audio if I attach speakers direct to the
3.5mm output.

>However, if you upgrade to a more recent ALSA, you should be able to get audio over HDMI working on more recent video cards GT210/220 and higher.

I am using one of these cards 210.  Perhaps that is the problem.

My ALSA is ALSA 1.0.21 what version do I need?

Is anyone running Mythbuntu 10.10 and tell me what version is
installed by default?

I am using Mythbuntu 10.04 at the moment is there a guide available to
get a newer version of ALSA installed?


More information about the mythtv-users mailing list