[mythtv-users] Trouble with lirc and HD-PVR on Fedora 12

Robert Middleswarth robert at middleswarth.net
Fri May 28 20:15:18 UTC 2010

On 04/13/2010 09:13 AM, Jarod Wilson wrote:
> On Tue, Apr 13, 2010 at 8:38 AM, John Welch<jrw3319 at gmail.com>  wrote:
>> On Tue, Apr 13, 2010 at 1:41 AM, Jarod Wilson<jarod at wilsonet.com>  wrote:
> ...
>>> There was a thread about this on either the lirc list or this list in
>>> just the past few weeks. I dunno what might have changed where, but
>>> lircd has used an int type for codes for some time now as far as I
>>> know (I rarely touch the userspace side, mostly just the kernel
>>> side...), and I believe the root problem is that the raw code values
>>> in that config file for a number of devices exceed the upper bound an
>>> int type can hold. I've been meaning to talk to Christoph about it.
>>> Never noticed it myself, as my box uses the 0_85 codes, which are all
>>> well within range.
>> Thanks Jarod.  For all I know the "warning" messages about the 10
>> digit codes were happening all along, even when I had things working.
> Possibly.
>> I really think my problem is more related to the fact that the lirc
>> device is not being created anymore in /dev, but rather now something
>> appears in /var/run/lirc.  Am I wrong in thinking that the lirc device
>> gets created when the module(s) load?
> The thing that shows up in /var/run/lirc is the lirc daemon socket.
> Its created when lircd is started.
>> Also, if this is the case, do
>> you know if something has changed with the most recent kernels /
>> modules that would have affected this behavior?
> You should still have a /dev/lircX device, which is created when an
> lirc_foo kernel driver (lirc_zilog in this case) is loaded. I'm not
> aware of anything that has changed in recent kernels that would break
> this, but I've not been using lirc_zilog on any regular basis either.
> In fact, I've just replaced the frontend box next to the cable box my
> hdpvr is connected to, and haven't yet got around to setting things up
> again...
> Okay, just tried loading lirc_zilog, looks like its not binding to the
> hdpvr at all. A quick poke at the system with i2cdetect lists no i2c
> devices present, so I'm guessing someone has gone and disabled/removed
> the patch that enabled the IR part in the hdpvr driver... Bah! Somehow
> or another, the patch file is completely empty now. Well, that
> certainly explains why it ain't working... I'll touch that up when I
> have a chance. :\

Any word when it will be put back in.  I am currently using mythbuntu 
but am getting ready to switch back to mythdora for better lirc 
support.  Any idea when a fix for this will go in?


More information about the mythtv-users mailing list